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FIX: A file is not removed from an FTP location when you use BizTalk Server 2006 R2 or BizTalk Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft BizTalk Server 2006 R2 or BizTalk Server 2009:
  • You retrieve a file from a subfolder at an FTP location by using an FTP receive location.
  • While BizTalk Server 2006 R2 is processing this file, the FTP connection times out.
  • After some time, BizTalk Server 2006 R2 opens a new FTP session, and then issues a DELE command.
In this scenario, BizTalk Server 2006 R2 cannot delete the received file from the subfolder at the FTP location. Additionally, the new FTP session is closed, and you can see log entries in the BizTalk Server 2006 R2 FTP log that resemble the following:
< 220 Microsoft FTP Service
> USER anonymous
< 331 Anonymous access allowed, send identity (e-mail name) as password.
> PASS xxxx
< 230 Anonymous user logged in.
> PWD
< 257 "/" is current directory.
> DELE file_name
< 550 file_name: The system cannot find the file specified.
> QUIT
< 221
When the BizTalk Server 2006 R2 or BizTalk Server 2009 next polls the FTP location, BizTalk Server 2006 R2 or BizTalk Server 2009 opens the FTP location and downloads the same file again.

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Cause

This problem occurs because BizTalk Server 2006 R2 or BizTalk Server 2009 does not issue a CWD command before it issues the DELE command. Therefore, instead of trying to delete the file from the configured subfolder, BizTalk Server 2006 R2 or BizTalk Server 2009 tries to delete the file from the FTP root directory.

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Resolution

Cumulative updated information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2429050 Cumulative update package 1 for BizTalk Server 2009

Hotfix information

For BizTalk Server 2006 R2

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

There are no prerequisites for installing this hotfix package.

Restart requirement

You do not have to restart the computer after you apply this hotfix package. However, you must restart the BizTalk Server Application service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix package.

File information

The English (United States) version of this hotfix package uses a Microsoft Windows Installer package to install the hotfix package. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Interop.xceedftplib.dll3.6.1550.259,22430-Oct-200916:15x86
Microsoft.biztalk.coreadapter.dll3.6.1550.2104,32030-Oct-200916:15x86
Xceedftpbiztalk.dll3.6.1550.2300,88030-Oct-200916:17x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

For BizTalk Server 2006 R2 SP1


The hotfix that resolves this problem is included in cumulative update package 1 for BizTalk Server 2006 R2 SP1.�

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

982061 Cumulative update package 1 for BizTalk Server 2006 R2 Service Pack 1 �

For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

974563 List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
203907 Information on BizTalk Server hot fixes
For more information about how to configure an FTP receive location, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbbtsadapters, kbbiztalk2006r2presp2fix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbqfe, KB976891

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Article Info
Article ID : 976891
Revision : 5
Created on : 12/8/2010
Published on : 12/8/2010
Exists online : False
Views : 625