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Error message when a Windows Server 2008 R2-based or a Windows 7-based computer enters hibernation: "STOP: 0x0000000A"


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

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Symptoms

On a computer that is running Windows Server 2008 R2 or Windows 7, you receive an error message that resembles the following when the computer enters hibernation:
STOP: 0x0000000A (parameter1, parameter2, parameter3, parameter4)

IRQL_NOT_LESS_OR_EQUAL
Then, the computer restarts automatically.

Notes
  • The parameters in the error message vary, depending on the configuration of the computer and on the kind of problem.
  • Not all "Stop 0x0000000A" error messages are caused by this problem.

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Cause

This problem occurs because the Diskdump.sys driver incorrectly sets the I/O size to 0. When the system enters hibernation, the Diskdump.sys driver is responsible for writing memory contents into the Hiberfil.sys file. If the storage device that contains the Hiberfil.sys file is busy when the device receives an I/O request from the Diskdump.sys driver, the driver tries to send the I/O request later. However, the Diskdump.sys driver incorrectly sets the I/O size to 0 when it resends the I/O request. Therefore, the system accesses an invalid memory address and you receive the error message.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows 7
  • Windows Server 2008 R2

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

File information

The global version of this hotfix has the file attributes (or later versions of file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Important Windows 7 and Windows Server 2008 R2 hotfixes are included in the same package. However, only one of these products may be listed on the Hotfix Request page. To request the hotfix package that applies to both Windows 7 and Windows Server 2008 R2, select the product that is listed on the page.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7


File nameFile versionFile sizeDateTimePlatform
Diskdump.sys6.1.7600.2056226,71230-Oct-200908:59x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Diskdump.sys6.1.7600.2056227,20830-Oct-200909:37x64

For all supported IA-64-based versions of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Diskdump.sys6.1.7600.2056254,34430-Oct-200908:12IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7


File nameFile versionFile sizeDateTimePlatform
Package_for_kb976746_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,45830-Oct-200912:11Not Applicable
X86_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20562_none_6730c9db11a9df58.manifestNot Applicable2,15030-Oct-200910:42Not Applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20562_none_c34f655eca07508e.manifestNot Applicable2,15230-Oct-200910:05Not Applicable
Package_for_kb976746_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,68830-Oct-200912:11Not Applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-diskdump_31bf3856ad364e35_6.1.7600.20562_none_67326dd111a7e854.manifestNot Applicable2,15130-Oct-200909:53Not Applicable
Package_for_kb976746_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,68330-Oct-200912:11Not Applicable

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Keywords: kb, kbmdd, kbexpertiseinter, kbsurveynew, kbqfe, kbhotfixserver

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Article Info
Article ID : 976746
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 311