Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A VSS writer is not successful when it tries to create a snapshot on a computer that is running Windows Server 2003 SP2 if the VSS writer has a dependency with another writer that has no local components in the component list


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A Volume Shadow Copy Service (VSS) writer depends on another writer on a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • This other writer has a component list that has no local components.
In this scenario, the VSS writer is not successful when it tries to create a snapshot, and you receive the following error code:
0x80042301


For example, you do the following:
  • You use a backup application to back up a Microsoft Windows SharePoint farm on computer that is running a Windows Server 2003 SP2. This backup application uses VSS in the backup process.
  • You host all components of the SharePoint farm on some remote computers.
In this example, the SharePoint farm backup fails, and you receive the error message.

↑ Back to the top


Cause

The Volume Shadow Copy Service (VSS) returns an instance of the error 0x80042301 (VSS_E_BAD_STATE) if a snapshot does include remote components and does not include any local components.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2

File nameFile versionFile sizeDateTimePlatformSP requirement
W03a3409.dll5.2.3790.459043,52016-Sep-200912:16x86SP2
Swprv.dll5.2.3790.4620288,25617-Nov-200913:03x86SP2
Vssapi.dll5.2.3790.4620571,90417-Nov-200913:03x86SP2
Vssvc.exe5.2.3790.4620838,65617-Nov-200909:06x86SP2
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP Professional x64 Edition

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
W03a3409.dll5.2.3790.459044,03217-Nov-200911:43x64SP2Not Applicable
Swprv.dll5.2.3790.4620693,76017-Nov-200911:43x64SP2Not Applicable
Vssapi.dll5.2.3790.46201,348,09617-Nov-200911:43x64SP2Not Applicable
Vssvc.exe5.2.3790.46202,070,52817-Nov-200911:43x64SP2Not Applicable
Wvssapi.dll5.2.3790.4620571,90417-Nov-200911:44x86SP2WOW
Ww03a3409.dll5.2.3790.459043,52017-Nov-200911:44x86SP2WOW
For all supported IA-64-based versions of Windows Server 2003 SP2

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Swprv.dll5.2.3790.4620871,93617-Nov-200911:36IA-64SP2Not Applicable
Vssapi.dll5.2.3790.46201,674,24017-Nov-200911:36IA-64SP2Not Applicable
Vssvc.exe5.2.3790.46202,597,88817-Nov-200911:36IA-64SP2Not Applicable
W03a3409.dll5.2.3790.459042,49617-Nov-200911:36IA-64SP2Not Applicable
Wvssapi.dll5.2.3790.4620571,90417-Nov-200911:36x86SP2WOW
Ww03a3409.dll5.2.3790.459043,52017-Nov-200911:36x86SP2WOW

↑ Back to the top


Workaround

To work around the issue, create a local dependent component that is located on the local volume and that is included in the snapshot.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about component dependencies, visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB976461

↑ Back to the top

Article Info
Article ID : 976461
Revision : 1
Created on : 12/28/2009
Published on : 12/28/2009
Exists online : False
Views : 575