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Stop error message when you retrieve WMI connection statistics for iSCSI after you change the iSCSI configurations on a computer that is running Windows Server 2008 R2 or Windows 7: "0x00000019 BAD_POOL_HEADER"


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Symptoms

You receive the following Stop error message on a computer that is running Windows Server 2008 R2 or Windows 7:
0x00000019 (00000021, parameter2, parameter3, parameter4)

BAD_POOL_HEADER

This behavior occurs when you change the Internet SCSI (iSCSI) configurations on the computer and you retrieve some iSCSI connection statistics by using Windows Management Instrumentation(WMI).



Note
  • The configuration of the computer determines the parameters in this error message.
  • Not all "0x00000019" Stop errors are caused by this problem.

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Cause

The iSCSI driver (Msiscsi.sys) does not manage allocated pool space correctly. This behavior leads to pool corruption. Therefore, when the corrupted pool is accessed, the system triggers the stop code 0x00000019.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows 7

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 R2 and Windows 7 file information note

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are
listed separately
. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7

File nameFile versionFile sizeDateTimePlatform
Iscsi.infNot Applicable7,31224-Oct-200900:14Not Applicable
Iscsilog.dll6.1.7600.1638516,38414-Jul-200901:06x86
Msiscsi.sys6.1.7600.20557186,95224-Oct-200907:00x86
For all supported x64-based versions of Windows Server 2008 R2 and of Windows7

File nameFile versionFile sizeDateTimePlatform
Iscsi.infNot Applicable7,32024-Oct-200900:14Not Applicable
Iscsilog.dll6.1.7600.1638516,38414-Jul-200901:28x64
Msiscsi.sys6.1.7600.20557224,84024-Oct-200907:41x64
For all supported Itanium-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Iscsi.infNot Applicable7,31624-Oct-200900:11Not Applicable
Iscsilog.dll6.1.7600.1638516,38414-Jul-200901:36IA-64
Msiscsi.sys6.1.7600.20557513,60824-Oct-200906:11IA-64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2 and for Windows 7

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Package_for_kb976443_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,71424-Oct-200910:15Not Applicable
X86_iscsi.inf_31bf3856ad364e35_6.1.7600.20557_none_3d462ae06dfdc36b.manifestNot Applicable2,45624-Oct-200910:17Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

File nameFile versionFile sizeDateTimePlatform
Amd64_iscsi.inf_31bf3856ad364e35_6.1.7600.20557_none_9964c664265b34a1.manifestNot Applicable2,46024-Oct-200910:19Not Applicable
Package_for_kb976443_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,72424-Oct-200910:15Not Applicable
Additional files for all supported Itanium-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Ia64_iscsi.inf_31bf3856ad364e35_6.1.7600.20557_none_3d47ced66dfbcc67.manifestNot Applicable2,45824-Oct-200910:15Not Applicable
Package_for_kb976443_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,44424-Oct-200910:15Not Applicable

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References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

974201 Stop error message when you retrieve WMI connection statistics for iSCSI after you change the iSCSI configurations on a computer that is running Windows Server 2008 or Windows Vista: "0x00000019 BAD_POOL_HEADER"

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Keywords: kbmdd, kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, kb

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Article Info
Article ID : 976443
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 425