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After you change the SATA mode of disk devices to use the AHCI specification, the computer or certain applications randomly stop responding for 60 seconds or for longer in Windows 7 and in Windows Server 2008 R2


View products that this article applies to.

Symptoms

You have a computer that is running Windows Server 2008 R2 or Windows 7. In the BIOS setup, you change the Serial Advanced Technology Attachment (SATA) mode of a disk device to use the Advanced Host Controller Interface (AHCI) specification. After this change takes effect, the computer randomly stops responding for 60 seconds or for longer.

This issue may affect Windows Explorer and any other application that performs I/O operations on the SATA/AHCI device.

Note The issue occurs frequently under heavy disk I/O conditions.

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Cause

This issue occurs because the AHCI driver (Msahci.sys) does not follow AHCI specifications to access related registers. This behavior may lead to a race condition between the interrupt handler in the driver and the hardware device. When the race condition occurs, the AHCI driver does not detect that some I/O requests are completed until the time-out handler collects these requests 60 seconds later.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7 or Windows Server 2008 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 and Windows Server 2008 R2 hotfixes are included in the same packages. However, only one of these products may be listed on the "Hotfix Request" page. To request the hotfix package that applies to both Windows 7 and Windows Server 2008 R2, just select the product that is listed on the page.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.014,40014-Jul-200901:26x86
Cmdide.sys2.0.7.015,95214-Jul-200901:26x86
Msahci.sys6.1.7600.2054527,72009-Oct-200906:07x86
Mshdc.infNot Applicable51,01608-Oct-200923:02Not Applicable
Viaide.sys6.0.6000.17016,97614-Jul-200901:19x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.015,44014-Jul-200901:52x64
Cmdide.sys2.0.7.017,48814-Jul-200901:52x64
Msahci.sys6.1.7600.2054530,28009-Oct-200907:01x64
Mshdc.infNot Applicable51,17608-Oct-200923:14Not Applicable
Viaide.sys6.0.6000.17017,48814-Jul-200901:45x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Aliide.sys1.2.0.019,02414-Jul-200901:57IA-64
Cmdide.sys2.0.7.026,70414-Jul-200901:57IA-64
Msahci.sys6.1.7600.2054569,19209-Oct-200913:41IA-64
Mshdc.infNot Applicable48,68408-Oct-200923:11Not Applicable
Viaide.sys6.0.6000.17027,71214-Jul-200901:56IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Package_for_kb976418_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,71409-Oct-200914:34Not Applicable
X86_mshdc.inf_31bf3856ad364e35_6.1.7600.20545_none_ddc35c9e9bda913a.manifestNot Applicable6,63209-Oct-200914:44Not Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Amd64_mshdc.inf_31bf3856ad364e35_6.1.7600.20545_none_39e1f82254380270.manifestNot Applicable6,63609-Oct-200914:50Not Applicable
Package_for_kb976418_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,72409-Oct-200914:34Not Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Ia64_mshdc.inf_31bf3856ad364e35_6.1.7600.20545_none_ddc500949bd89a36.manifestNot Applicable6,11209-Oct-200914:34Not Applicable
Package_for_kb976418_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,44409-Oct-200914:34Not Applicable

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References

For more information about the AHCI specification, visit the following Intel Web site:

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Keywords: kb, kbsurveynew, kbexpertiseinter, kbqfe, kbautohotfix, kbhotfixserver

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Article Info
Article ID : 976418
Revision : 1
Created on : 1/7/2017
Published on : 10/10/2011
Exists online : False
Views : 284