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FIX: In Commerce Server 2007 SP2 or in Commerce Server 2009, the Web Server Log Import DTS task shows all log files that you import and does not exclude log files that you have imported already


View products that this article applies to.

Symptoms

Considering the following scenario:
  • You have a computer that is running Microsoft Commerce Server 2007 Service Pack 2 (SP2) or Microsoft Commerce Server 2009.
  • You import Web server log files that are in a specified path into a data warehouse.

    Note To do this, you use the Data Warehouse Import Wizard, or you run the Web Server Log Import Data Transformation Services (DTS) task.
  • The Web server log files are generated by Internet Information Services (IIS) 7.0 Web sites.
In this scenario, the DTS task continuously shows all the log files that are in the specified path. However, you expect the DTS task to exclude the Web server log files that were imported already.

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Cause

The default Web server log files in IIS 7.0 are saved in UTF-8 format. Additionally, the file names have "u_ex" prefixes. Therefore, the Web Server Log Import DTS task cannot correctly determine whether the Web log files were imported.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 SP2 or Commerce Server 2009 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Commerce Server 2007
File nameFile versionFile sizeDateTimePlatform
Csdwdtslogimports.dll6.0.4109.28559,05628-Sep-200910:44x86

For all supported x86-based versions of Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Csdwdtslogimports.dll6.0.4171.9559,05620-Oct-200912:50x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to manage a data warehouse, visit the following Microsoft Developer Network (MSDN) Web site: For more information about how to specify the location of a log file to a data warehouse , visit the following MSDN Web site:

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Keywords: KB975996, kbqfe, kbsurveynew, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 975996
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 440