Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

After you enable large pages for a process in Windows 7 or in Windows Server 2008 R2, the process stops responding intermittently


View products that this article applies to.

Symptoms

On a computer that is running Windows 7 or Windows Server 2008 R2, you enable large pages for a process. Then, the process stops responding intermittently.

For example, you enable a 64-bit version of Microsoft SQL Server 2008 to use large pages on a computer that is running Windows Server 2008 R2. In this situation, access violations may occur. Additionally, the SQL Server service stops unexpectedly.

Note For more information about how to configure SQL Server 2008 to use large pages in Windows Server 2008 R2, please refer to the "More Information" section.

↑ Back to the top


Cause

This issue occurs because an internal function sets the wrong data when an executable is mapped by using large pages.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2.

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). The dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and times may change when you perform certain operations on the files.

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes that are listed on the Hotfix Request page may apply to only one of these operating systems. To request the hotfix package that applies to both Windows 7 and to Windows Server 2008 R2, select the appropriate product that is listed on the page.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Ntdll.dll6.1.7600.205481,286,12815-Oct-200906:14
For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Ntdll.dll6.1.7600.205482,782,40015-Oct-200905:10
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Ntdll.dll6.1.7600.205481,736,79215-Oct-200906:54

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about large page support, visit the following Microsoft Developer Network (MSDN) Web site:For more information about Debugging Tools for Windows, visit the following Microsoft Web site:

How to configure SQL Server 2008 to use large pages in Windows Server 2008 R2

  1. Open the folder in which Debugging Tools for Windows is installed.
  2. Start the GFlags utility.
  3. In the Global Flags dialog box, click the Image File tab.
  4. In the Image: (TAB to refresh) box, type Sqlservr.exe, and then press the TAB key.
  5. Click to select the Load image using large pages if possible check box, and then click OK.

↑ Back to the top


Keywords: kbfix, kbexpertiseadvanced, kbautohotfix, kbsurveynew, kbqfe, KB975992

↑ Back to the top

Article Info
Article ID : 975992
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 403