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A hotfix is available that addresses the issues that occur when you perform a host-level backup of a Hyper-V VM on a computer that is running Windows Server 2008


View products that this article applies to.

Symptoms

When you perform a host-level backup of a Hyper-V virtual machine (VM) on a computer that is running Windows Server 2008, you may experience one of the following issues.

Issue 1

Consider the following additional conditions:
  • The VM is running Microsoft Exchange Server or a transactional application.
  • A backup application is running on the VM.
  • The backup application is configured to back up Exchange Server or the transactional application.
When the host-level backup of the VM is completed, the transaction logs for Exchange Server or for the transactional application are deleted. Therefore, the backup application cannot back up Exchange Server or the transactional application.

Issue 2

Consider the following additional conditions:
  • The VM is running Windows Server 2003.
  • Some Internet SCSI (iSCSI) connections are created on the VM.
When you perform a host-level backup of the VM, you receive error code 0x800423f4. Additionally, the following error message is logged in the Hyper-V-VMMS log:
The number of reverted volumes does not match the number of volumes in the snapshot set for virtual machine "'VM_Name' (Virtual machine ID <VM_GUID>)".
Note The Hyper-V-VMMS log is located in the following path in Event Viewer:
Application and Services Logs\Microsoft\Windows

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Cause

Cause of Issue 1

When you perform a host-level backup of a VM, the Hyper-V Volume Shadow Copy Service (VSS) writer requests a VSS full backup of the VM.

Note After you apply this hotfix, you can configure a setting that enables the Hyper-V VSS writer to ignore the VSS application writers on VMs. This behavior makes sure that the transaction logs are not deleted when you perform a host-level backup of the VM. For more information about how to configure this setting, see the "How to enable the Hyper-V VSS writer to ignore the VSS application writers" topic in the "Resolution" section.

Cause of Issue 2

When you perform a host-level backup of a VM, the Hyper-V VSS writer makes a call to the VM to check whether any iSCSI connection exists. By default, this call times out after 60 seconds. If the VM does not respond within 60 seconds, the Hyper-V VSS writer incorrectly behaves as if no iSCSI connection exists on the VM. Therefore, the host-level backup of the VM fails.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

How to install this hotfix

After you apply this hotfix, you must update the Integration Services component on the VMs. To do this, follow these steps:
  1. In Hyper-V Manager, connect to a VM.
  2. On the Action menu, click Insert Integration Services Setup Disk.
  3. Follow the instructions to install the Integration Services component on the VM.
  4. Repeat step 1-3 on the other VMs.

How to enable the Hyper-V VSS writer to ignore the VSS application writers

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. In Registry Editor, locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtualization\VssRequestor
  2. Create a registry entry of the REG_DWORD type.
  3. Set the name of the registry entry to BackupType.
  4. Set the value of the registry entry to 1.

    Note If you set the value to 0, the Hyper-V VSS writer does not ignore the VSS application writers on the VMs.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and times for these files are listed in Coordinated Universal Time (UTC). The dates and times for these files on your local computer are displayed in your local time and with your current daylight saving time (DST) bias. Additionally, the dates and times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista and Windows Server 2008 updates are included in the same packages. However, only one of these products may be listed on the "Hotfix Request" page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Windows5.x-hypervintegrationservices-x64.exe6.2.29.01,087,17629-Sep-200912:50x86
Vmms.exe6.0.6002.222333,910,65629-Sep-200909:59x64
Windows5.x-hypervintegrationservices-x86.exe6.2.29.0869,57629-Sep-200912:56x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_3b52d263ed104013ac47bc243fb9a4e8_31bf3856ad364e35_6.0.6002.22233_none_c0a8ce9105b34dd4.manifest
File versionNot applicable
File size703
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File nameAmd64_8050715fa547f104d2e0876d524ad333_31bf3856ad364e35_6.0.6002.22233_none_28e12322aa79f8c4.manifest
File versionNot applicable
File size1,082
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File nameAmd64_a715622600d8b01ad314651d9d620b4f_31bf3856ad364e35_6.0.6002.22233_none_585bcacd00671430.manifest
File versionNot applicable
File size1,082
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.0.6002.22233_none_309e6ccf590b2104.manifest
File versionNot applicable
File size4,244
Date (UTC)29-Sep-2009
Time (UTC)13:51
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-g..aller-win60-package_31bf3856ad364e35_6.0.6002.22233_none_96ea4a038a1beffd.manifest
File versionNot applicable
File size2,611
Date (UTC)29-Sep-2009
Time (UTC)13:58
PlatformNot applicable
File nameAmd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.0.6002.22233_none_95074a892da3b054.manifest
File versionNot applicable
File size250,972
Date (UTC)29-Sep-2009
Time (UTC)13:47
PlatformNot applicable
File namePackage_1_for_kb975925~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size2,223
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_2_for_kb975925~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size3,083
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_3_for_kb975925~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size2,223
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_4_for_kb975925~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size3,083
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_for_kb975925_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size1,814
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_for_kb975925_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size1,431
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_for_kb975925_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size1,817
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File namePackage_for_kb975925_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot applicable
File size1,439
Date (UTC)30-Sep-2009
Time (UTC)09:30
PlatformNot applicable
File nameX86_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.0.6002.22233_none_d47fd14ba0adafce.manifest
File versionNot applicable
File size4,228
Date (UTC)29-Sep-2009
Time (UTC)14:02
PlatformNot applicable
File nameX86_microsoft-hyper-v-g..aller-win60-package_31bf3856ad364e35_6.0.6002.22233_none_3acbae7fd1be7ec7.manifest
File versionNot applicable
File size2,607
Date (UTC)29-Sep-2009
Time (UTC)14:09
PlatformNot applicable

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Keywords: KB975925, kbhotfixserver, kbsurveynew, kbexpertiseadvanced, kbqfe, kbfix, kbautohotfix, kbhyperv

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Article Info
Article ID : 975925
Revision : 3
Created on : 11/22/2010
Published on : 11/22/2010
Exists online : False
Views : 327