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FIX: Error message when you use the POP3 adapter in BizTalk Server 2006 R2 or BizTalk Server 2009: "The POP3 adapter received a response line from a server that contains more than 512 characters"


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2006 R2 or BizTalk Server 2009, when you use a Post Office Protocol 3 (POP3) adapter to retrieve data from a server that houses Post Office Protocol 3 (POP3) mailboxes, occasionally the POP3 adapter does not work. Then a warning message that resembles the following is logged in the application event log:
Event Type: Warning
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5740
Description: The adapter "POP3" raised an error message.
Details: The POP3 adapter received a response line from a server that contains more than 512 characters. URL: POP3://<URI>

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Cause

This problem occurs because the POP3 adapter has a limit for the line length of 8190 characters. When the incoming message contains a response line that is over this limit, this problem occurs.

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Resolution

Cumulative updated information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2429050� Cumulative update package 1 for BizTalk Server 2009
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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.adapter.runtime.dll3.6.1548.283,84817-Sep-200914:39x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the POP3 adapter, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbbtsadapters, kbbiztalk2006r2sp1fix, kbexpertiseadvanced, kbautohotfix, kbsurveynew, kbqfe, kbbiztalk2009presp1fix, KB975826

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Article Info
Article ID : 975826
Revision : 2
Created on : 12/8/2010
Published on : 12/8/2010
Exists online : False
Views : 440