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FIX: Outgoing batch creation fails if individual messages contain trailing delimiters


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In Microsoft BizTalk Accelerator for HL 7 (BTAHL7) Configuration Explorer, you enable the Allow trailing delimiters (separators) option under the Validation tab of your trading party.
  • In a create-batch scenario, one of the separate input messages contains trailing delimiters.

    Note The Create-batch scenario is a scenario when BTAHL7 combines separate input messages into an output batch. For more information, refer to the "More information" section.
In this scenario, the Allow trailing delimiters (separators) option is not applied. Therefore, the outgoing batch creation fails. Additionally, an error message is logged in application event log that resembles the following:

Event Type: Error
Event Source: BizTalk Accelerator for HL7
Event ID: 4133
Description: Error happened in body during serialization Error # 1
Segment Id: PID_PatientIdentification
Sequence Number: <Sequence Number>
Field Number: <Field number>
Error Number: 207
Error Description: Application internal error
Encoding System: HL7nnnn
Alternate Error Number: Z100
Alternate Error Description: Trailing delimiter found
Alternate Encoding System: HL7-BTA

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Cause

This problem occurs because of an error in the BizTalk Accelerator for HL7 2.0 version.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 R2 and Microsoft BizTalk Accelerator for HL7 2.0 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk host instance after you apply this hotfix. For more information about this procedure, refer to the Readme.txt file that is included in the hotfix package.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft BizTalk Server 2006 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.solutions.btahl7.hl72fasm.dll2.0.314.059,25622-Sep-200923:24x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to configure validation settings, visit the following Microsoft Developer Network (MSDN) Web site: For more information about the Create-Batch scenario, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbbtsaccelerators, kbbiztalk2006r2sp1fix, kbsurveynew, kbqfe, kbhotfixserver, kbfix, kbautohotfix, KB975761

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Article Info
Article ID : 975761
Revision : 2
Created on : 10/29/2009
Published on : 10/29/2009
Exists online : False
Views : 393