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Some function keys or keyboard shortcuts do not work correctly on a computer that is running Windows 7


View products that this article applies to.

Symptoms

On a computer that is running Windows 7, some function keys and keyboard shortcuts do not work correctly. Every time that you press a function key or keyboard shortcut, the corresponding function is triggered two times.

For example, assume that your computer keyboard has a built-in Calc key that lets you start Calculator. When you press the Calc key, two instances of Calculator start. Or, assume that you have a Mute key on the keyboard. When you press the Mute key or the Fn+F6 keyboard shortcut to mute or unmute the system sound, the sound is not muted or unmuted.

Notes

This problem is a timing related issue. Therefore, the chances of the problem occurring can be influenced by different factors. Observed examples that increased the chances of the problem occurring include the following:

  • On a localized version of Windows that has a language bar, you dock the language bar in the taskbar.

  • On a computer that has a hyper-threading CPU, you disable the hyper-threading in the BIOS.
  • You attach a new hardware and install the respective drivers on the computer.

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Cause

This problem occurs because of an error in certain hook logic in Windows Explorer of Windows 7. This error causes Windows 7 to send two commands every time that you press a function key or keyboard shortcut. In the mute example that is described in the “Symptoms” section, Windows 7 sends two commands to the sound mixer for each mute or unmute request. Therefore, for the mute and unmute operations, the second command undoes the operation of the first command. This behavior makes it appear that the mute or unmute function does not work.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows 7 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows 7RTMGDR
    6.1.760
    0.20xxx
    Windows 7RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
Windows 7, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Explorer-ppdlic.xrm-msNot Applicable3,06506-Oct-200906:01Not Applicable
Explorer.exe6.1.7600.164342,613,24806-Oct-200905:53x86
Explorer-ppdlic.xrm-msNot Applicable3,06506-Oct-200906:15Not Applicable
Explorer.exe6.1.7600.205422,613,24806-Oct-200906:06x86
Windows 7, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Explorer-ppdlic.xrm-msNot Applicable3,06506-Oct-200906:50Not Applicable
Explorer.exe6.1.7600.164342,868,73606-Oct-200906:35x64
Explorer-ppdlic.xrm-msNot Applicable3,06506-Oct-200906:42Not Applicable
Explorer.exe6.1.7600.205422,868,73606-Oct-200906:31x64
Explorer.exe6.1.7600.164342,613,24806-Oct-200905:53x86
Explorer.exe6.1.7600.205422,613,24806-Oct-200906:06x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbhotfixserver, kbqfe, kbautohotfix, kbexpertisebeginner, kbsurveynew, kbbug

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Article Info
Article ID : 975741
Revision : 3
Created on : 4/17/2018
Published on : 4/17/2018
Exists online : False
Views : 501