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A snapshot may become corrupted when the Volume Shadow Copy Service (VSS) snapshot providers take more than 10 seconds to create it on a computer that is running Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Volume Shadow Copy Service (VSS) does not return an error when snapshot providers take more than 10 seconds to create a snapshot on a computer that is running Windows 7 or Windows Server 2008 R2. Therefore, you are not aware of potential data corruption until you try to restore a created snapshot.

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Cause

Volume Shadow Copy Service (VSS) gives providers 10 seconds to block I/O requests and to create a snapshot. When a snapshot is created or the timer reaches 10 seconds, VSS releases writers to resume I/O requests. If a snapshot is not created within 10 seconds, snapshot corruption may occur. Therefore, VSS is supposed to return an error when the 10-second limitation is reached.

However, VSS in Windows Server 2008 R2 and in Windows 7 does not return the VSS_E_HOLD_WRITES_TIMEOUT error when a snapshot provider takes more than 10 seconds to create a snapshot. This snapshot is created without any error returned.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows 7

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 R2 and Windows 7 file information note

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7

File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7600.20528245,33616-Sep-200905:28x86
Volume.infNot Applicable1,94815-Sep-200922:59Not Applicable
For all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7600.20528294,98416-Sep-200905:52x64
Volume.infNot Applicable1,96815-Sep-200922:48Not Applicable
For all supported IA-64-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Volsnap.sys6.1.7600.20528675,41616-Sep-200904:51IA-64
Volume.infNot Applicable1,95815-Sep-200922:46Not Applicable


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2 and for Windows 7

Additional files for all supported x86-based versions of Windows 7

File nameFile versionFile sizeDateTimePlatform
Package_for_kb975688_rtm~31bf3856ad364e35~x86~~6.1.1.0.mumNot Applicable1,71416-Sep-200916:07Not Applicable
X86_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165a8cbb7652d18e.manifestNot Applicable2,08316-Sep-200907:08Not Applicable
Additional files for all supported x64-based versions of Windows Server 2008 R2 and of Windows 7

File nameFile versionFile sizeDateTimePlatform
Amd64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_7279283f2eb042c4.manifestNot Applicable2,08716-Sep-200906:13Not Applicable
Package_for_kb975688_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable1,72416-Sep-200916:07Not Applicable
Additional files for all supported Itanium-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Ia64_volume.inf_31bf3856ad364e35_6.1.7600.20528_none_165c30b17650da8a.manifestNot Applicable2,08516-Sep-200906:16Not Applicable
Package_for_kb975688_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,44416-Sep-200916:07Not Applicable

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References

For more information about the time limitation to create VSS shadow copies, click the following article number to view the sixth step in the section "How Shadow Copies Are Created" in the following Microsoft Web site:

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Keywords: kbqfe, kbhotfixserver, kbsurveynew, kbautohotfix, kbexpertiseinter, kbbug, kbfix, KB975688

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Article Info
Article ID : 975688
Revision : 3
Created on : 11/4/2009
Published on : 11/4/2009
Exists online : False
Views : 447