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Error message when you use an application that monitors the event log to open an event log file on a computer that is running Windows Server 2003 SP2: "The event log file is corrupt"


View products that this article applies to.

Symptoms

When you use an application that monitors the event log, such as the Event Viewer, to open an event log file on a computer that is running Windows Server 2003 Service Pack 2 (SP2), you receive the following error message:
The event log file is corrupt.
Note You may experience event log corruption for many reasons. This hotfix fixes the event log corruption caused by only the specific reason that is mentioned in the "Cause" section.

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Cause

This problem occurs because an event log entry is missing a value for the "Computer name" field or for the "Source" field in the event log file. If an application calls the ReadEventLog function to retrieve event log entries, a STATUS_EVENTLOG_FILE_CORRUPT error code is returned. Therefore, the application displays an error message.

Many factors may cause an event log entry to be missing a value for the "Computer name" field or the "Source" field.

For example, an application calls the GetComputerName function to retrieve the computer name. Then, this application writes the returned value directly to a newly created event log entry without checking the value. However, because the memory of the computer is low, the GetComputerName function fails and returns a NULL value. In this example, the event log entry is missing a value for the "Computer name" field.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You have to restart the computer after you apply this hotfix.

For more information about how to install the Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 file information note

For all supported x86-based versions of Windows Server 2003

File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.2.3790.4589619,00814-Sep-200917:19x86
For all supported x64-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirement
Advapi32.dll5.2.3790.45891,065,47215-Sep-200906:03x64SP2
Wadvapi32.dll5.2.3790.4589619,00815-Sep-200906:03x86SP2
For all supported Itanium-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatformSP requirement
Advapi32.dll5.2.3790.45891,483,77615-Sep-200906:03IA-64SP2
Wadvapi32.dll5.2.3790.4589619,00815-Sep-200906:03x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbautohotfix, kbqfe, kbbug, kbfix, kbsurveynew, kbhotfixserver, KB975652

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Article Info
Article ID : 975652
Revision : 2
Created on : 10/14/2009
Published on : 10/14/2009
Exists online : False
Views : 319