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FIX: BizTalk host instances may crash with a System.OutOfMemoryException exception message in BizTalk Server


View products that this article applies to.

Symptoms

On a computer that is running Microsoft BizTalk Server, the BizTalk host instance may crash intermittently. Additionally, Event ID 5410 is logged in the application event log, with a warning message that resembles the following:

Event Type: Warning 
Event Category: (1) 
Event ID: 5410 
Description: An error has occurred that requires the BizTalk service to terminate. The most common causes are an unexpected out of memory error and an inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat. 
Error message: Exception of type System.OutOfMemoryException was thrown. 
Error source: 
BizTalk host name: BizTalkServerApplication 
When this problem occurs, BizTalk Server stops processing messages.

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Cause

This problem occurs because of an error in Microsoft.xlangs.basetypes.dll. Because of this error, the System.Security.Policy.Evidence objects consume lots of memory, but do not release the memory correctly.

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Resolution

Cumulative updated information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2429050� Cumulative update package 1 for BizTalk Server 2009
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Hotfix information


There are 3 versions of this hotfix:
  • BizTalk Server 2006
  • BizTalk Server 2006 R2
  • BizTalk Server 2009
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006, BizTalk Server 2006 R2 or BizTalk Server 2009 installed to apply this hotfix.

Restart information

You do not have to restart your computer after apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.BizTalk Server 2006
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.xlangs.basetypes.dll3.5.1791.0100,20004-Oct-200918:11x86
BizTalk Server 2006 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.xlangs.basetypes.dll3.6.1547.2100,21628-Aug-200909:16x86
Microsoft.xlangs.basetypes.dll3.6.1547.2100,21615-Oct-200917:49x64
BizTalk Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.xlangs.basetypes.dll3.8.413.2 104,312 18-Nov-200918:11x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about How to troubleshoot a memory leak or an out-of-memory exception in the BizTalk Server process, click the following article number to view the article in the Microsoft Knowledge Base:
918643� How to troubleshoot a memory leak or an out-of-memory exception in the BizTalk Server process
For more information about the BizTalk Server hot fixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907� Information on BizTalk Server hot fixes
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbbtsadmin, kbbiztalk2006r2sp1fix, kbexpertiseinter, kbfix, kbHotfixServer, kbqfe, kbbiztalk2009presp1fix, KB975118

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Article Info
Article ID : 975118
Revision : 5
Created on : 12/8/2010
Published on : 12/8/2010
Exists online : False
Views : 1027