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FIX: You cannot retrieve the latest inventory data by using Commerce Server APIs for the Inventory System in Commerce Server 2007


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft Commerce Server 2007.
  • You enable caching in the Catalog System.

    Note You can enable caching by setting the CacheEnabled property on the CacheConfiguration object to True.
  • You retrieve inventory data by using the Commerce Server APIs for the inventory system.
In this scenario, you find that the inventory data is not the latest data.

For example, you use the InventoryCatalog.GetSku method to obtain an InventorySku object. The data in the InventorySku object differs from the data in the InventorySkus table. You use the InventorySku.Refresh method to update the object. However, the data is still not updated.

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Cause

This problem occurs because the inventory data is part of the CatalogItem object. When you enable catalog caching in the Catalog System, the inventory data is cached as part of the CatalogItem object in the product catalog cache. You cannot update inventory data separately.

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Resolution

This hotfix changes the way inventory data is retrieved. When you call the inventory objects to obtain the inventory data, the data is retrieved directly from the inventory system database tables.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) and the Commerce Server Catalog Import Host COM+ application after you apply this hotfix.

To restart IIS, at a command prompt, type IISRESET /RESTART, and then press ENTER.

Note This action stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.catalogserver.dll6.0.4109.23751,47227-Aug-200914:44x86
Microsoft.commerceserver.catalog.dll6.0.4109.23960,37627-Aug-200914:44x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This hotfix includes two DLL updates. Therefore, if you want to uninstall this hotfix, you must remove the following two entries by using the Add or Remove Programs item in Control Panel.
  • Microsoft Commerce Server 2007 Client Tools SP2 - KB975086CT
  • Microsoft Commerce Server 2007 Enterprise Edition SP2 - KB975086
For more information about how to develop applications by using the inventory system, visit the following Microsoft Developer Network (MSDN) Web site:For more information about caching in the Catalog System, visit the following MSDN Web site:For more information about the InventoryCatalog.GetSku method, visit the following MSDN Web site:For more information about the InventorySku class, visit the following MSDN Web site:For more information about the CatalogItem class, visit the following MSDN Web site:

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Keywords: KB975086, kbautohotfix, kbqfe, kbsurveynew, kbexpertiseadvanced

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Article Info
Article ID : 975086
Revision : 3
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 373