Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An application or service that queries information about a failover cluster by using the WMI provider may experience low performance or a time-out exception


View products that this article applies to.

Symptoms

Consider the following scenario:
  • An application or service uses the Windows Management Instrumentation (WMI) interfaces to query a failover cluster for the configuration and state information.
  • There are many resources and groups on the failover cluster.

In this scenario, the application or service may experience low performance or a time-out exception.

For example, if you use the System Center Virtual Machine Manager to manage a virtual machine on the failover cluster, you may experience this issue.

↑ Back to the top


Cause

This problem occurs because the WMI provider responds to the query requests very slowly. The time that the WMI provider takes to complete the query requests affects the following performance measurements:

  • The ability and reliability of the service or application
  • The speed of generating a status report about the failover cluster
Therefore, a slow response of the WMI provider may cause the application or service to function abnormally.

↑ Back to the top


Resolution

This hotfix optimizes the targeted WMI queries to the WMI provider of the failover cluster. This optimization is performed so that the common queries perform quicker when many resources and groups are configured on the failover cluster

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running Windows Server 2008 R2 together with the Failover Clustering feature enabled.

Note This hotfix is for the failover cluster WMI provider and services only. You are not required to install this hotfix on any other computers that is connected to the Windows Server 2008 R2 failover cluster, or on any other client computer that is running Remote Server Administration Tools (RSAT).

Restart requirement

You do not have to restart the computer if you stop the Cluster service before you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008 R2 file information note

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are
listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.1.7600.205174,579,84028-Aug-200911:21x64
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll6.1.7600.20517540,16028-Aug-200911:23x64
Cluswmi.mofNot Applicable76,54028-Aug-200903:31Not Applicable
Cluswmiuninstall.mofNot Applicable17613-Jul-200920:22Not Applicable
For all supported Itanium-based versions of Windows Server 2008 R2

File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.1.7600.205177,699,45628-Aug-200909:36IA-64
File nameFile versionFile sizeDateTimePlatform
Cluswmi.dll6.1.7600.20517884,22428-Aug-200909:38IA-64
Cluswmi.mofNot Applicable76,54028-Aug-200903:25Not Applicable
Cluswmiuninstall.mofNot Applicable17613-Jul-200920:22Not Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Note This hotfix optimizes the following queries to the failover cluster WMI provider when many resources and groups are configured on the failover cluster:
Select * from MSCluster_Resource WHERE Type=’<resource type name>’ [OR Type=’<resource type name 2>’]
Select * from MSCluster_Resource WHERE Type='Generic Service' AND PrivateProperties.ServiceName='tssdis'
Select * from MSCluster_ResourceToDisk where GroupComponent='MSCluster_Resource.Name="<resource name>"'
Select * from MSCluster_ResourceToDisk where PartComponent='MSCluster_Disk.ID="<disk id>"'
Select * from MSCluster_DiskToDiskPartition where GroupComponent='MSCluster_Disk.ID="<disk id>"'
Select * from MSCluster_NodeToActiveGroup where PartComponent='MSCluster_ResourceGroup.Name="<group name>"'
Select * from MSCluster_NodeToActiveResource where PartComponent='MSCluster_Resource.Name="<resource name>"'
Select * from MSCluster_ResourceGroupToResource where GroupComponent='MSCluster_ResourceGroup.Name="<group name>"'
Select * from MSCluster_ResourceGroupToResource where PartComponent='MSCluster_Resource.Name="<resource name>"'
Select * from MSCluster_Resource where Type='Virtual Machine' and PrivateProperties.VmID='<vm id>'
Select * from MSCluster_Resource where Type='Virtual Machine Configuration' and PrivateProperties.VmID='<vm id>'
Select * from MSCluster_ResourceToDependentResource where Dependent='MSCluster_Resource.Name="<resource name>"'
Select * from MSCluster_ResourceToDependentResource where Antecedent='MSCluster_Resource.Name="<resource name>"'
Select * from MSCluster_ClusterSharedVolumeToPartition where GroupComponent='MSCluster_ClusterSharedVolume.Name="<CSV name>"'
Select * from MSCluster_ClusterSharedVolumeToResource where GroupComponent='MSCluster_ClusterSharedVolume.Name="<CSV name>"'
Select * from MSCluster_ClusterSharedVolumeToNode where GroupComponent='MSCluster_ClusterSharedVolume.Name="<CSV name>"'
Select * from MSCluster_AvailableDisk where ID='<disk id>'
Select * from MSCluster_Resource where ResourceClass='<resource class>'
Select * from MSCluster_Resource where Name = '<resource name>'
Select * from MSCluster_Node where Name = '<node name>'
Select * from MSCluster_Group where Name = '<group name>'
Select * from MSCluster_Network where Name = '<network name>'
Select * from MSCluster_NetworkInterface where Name = '<network interface>' and SystemName = '<node name>'
Select * from MSCluster_ResourceType where Name = '<resource type>'
select * from MSCluster_Disk
select * from MSCluster_Disk where ID='< disk id>'

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7600.20517_none_168de9add41fe04f.manifestNot Applicable7,43828-Aug-200917:35Not Applicable
Amd64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7600.20517_none_193be2f1d2657a2c.manifestNot Applicable6,66828-Aug-200917:33Not Applicable
Package_for_kb974930_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mumNot Applicable2,16228-Aug-200922:43Not Applicable
Wow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7600.20517_none_20e294000880a24a.manifestNot Applicable4,60428-Aug-200916:08Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008 R2


File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7600.20517_none_ba70f2201bc07815.manifestNot Applicable7,43628-Aug-200916:50Not Applicable
Ia64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7600.20517_none_bd1eeb641a0611f2.manifestNot Applicable6,66628-Aug-200916:49Not Applicable
Package_for_kb974930_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mumNot Applicable1,45628-Aug-200922:43Not Applicable
Wow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7600.20517_none_20e294000880a24a.manifestNot Applicable4,60428-Aug-200916:08Not Applicable

↑ Back to the top


Keywords: kbfix, kbbug, kbexpertiseinter, kbqfe, kbsurveynew, kbhotfixserver, kb, kbautohotfix

↑ Back to the top

Article Info
Article ID : 974930
Revision : 5
Created on : 9/18/2018
Published on : 9/18/2018
Exists online : False
Views : 346