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Colors are not displayed correctly when you view a JPEG image in Internet Explorer 8


View products that this article applies to.

Symptoms

When you use Windows Internet Explorer 8 to browse a Web page that contains some JPEG images, the colors in the image are displayed incorrectly. Components that are blue and components that are red are swapped in the affected images. For example, you see blue skin on people, or you see red water. This issue affects the whole color spectrum, not only red and blue.�
Note�To identify this problem, compare the way that an image is displayed in Internet Explorer 8 with the way the same image is displayed in Windows Photo Viewer. To do this comparison, right-click the image in Internet Explorer 8, save the image to the local disk, and then open the image in Photo Viewer. Photo Viewer displays the colors in the image correctly.

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Cause

This issue occurs when the format of the JPEG image contains certain color space values that Internet Explorer 8 misinterprets.

Internet Explorer 8 performs optimizations that are related to color processing. The JPEG decoder swaps the RGB_RED value and the RGB_BLUE value to improve performance in Internet Explorer 8. However, for certain formats of JPEG images, the optimization is incompatible. Therefore, this issue occurs when you view certain formats of JPEG images Internet Explorer 8.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Internet Explorer 8 installed on a computer that is running one of the following operating systems:
  • Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 3 (SP3)
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows Vista
  • Windows Server 2008

Restart requirement

You have to restart the computer after you apply this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

Security update information

To resolve this issue, install the most recent cumulative security update for Internet Explorer. To do this, visit the following Microsoft website: For more technical information about the most recent cumulative security update for Internet Explorer, visit the following Microsoft website: Note This hotfix was first included in security update : 980182 MS10-018: Cumulative security update for Internet Explorer.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Internet Explorer 8 for Windows XP SP2
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.0.6001.229185,942,27201-Sep-200904:51x86
For all supported x86-based versions of Internet Explorer 8 for Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.0.6001.229185,942,27231-Aug-200917:12x86
For all supported x86-based versions of Internet Explorer 8 for Windows Server Vista and for Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.0.6001.229175,941,76025-Aug-200914:28x86
Mshtml.tlb8.0.6001.229171,638,91225-Aug-200912:52Not Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB974895, kbqfe, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 974895
Revision : 4
Created on : 5/17/2013
Published on : 5/17/2013
Exists online : False
Views : 390