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FIX: An Acknowledgement (ACK) is not sent back to the source application when you use BizTalk Server Accelerator for HL7 v1.3 in a BizTalk Server 2006 environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a computer that is running BizTalk Server 2006, you use Microsoft BizTalk Server Accelerator for HL7 v1.3 to process HL7 messages.
  • You change the standard namespace in HL7 schemas as outlined in the HL7 v2 Developer Guide. For example, you change the standard namespace from http://microsoft.com/HealthCare/HL7/2X to http://HIS/HL7/2X.
  • In the BTAHL7 Configuration Explorer, you enable the sending back Acknowledgement (ACK) option to the sending party.
  • BizTalk Server receives an HL7 message from the sending party.
In this scenario, the HL7 parser cannot return an ACK to the source application as expected. Additionally, you may find events in the Application event log that resemble the following:

Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006 
Event ID: 5720
Description:  There was a failure executing the send pipeline: "BTAHL72XPipelines.BTAHL72XSendPipeline, BTAHL72XPipelines, Version=1.3.0.0,  Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "BTAHL7 2.X Assembler" Send Port: "<Send Port>" URI: "<URI>" Reason: Finding the  document specification by message type "http://microsoft.com/HealthCare/HL7/2X#ACK_24_GLO_DEF" failed. Verify the schema deployed properly. 

Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006 
Event ID: 5754
Description:  A message sent to adapter "FILE" on send port "<Send Port>" with URI "<URI>� is suspended. 
 Error details: There was a failure executing the send pipeline: "BTAHL72XPipelines.BTAHL72XSendPipeline, BTAHL72XPipelines,  Version=1.3.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "BTAHL7 2.X Assembler" Send Port: "<Send Port>" URI: "<URI>"  Reason: Finding the document specification by message type "http://microsoft.com/HealthCare/HL7/2X#ACK_24_GLO_DEF" failed. Verify the schema  deployed properly.   
 MessageId:  {GUID}
 InstanceID: {GUID}

Notes
  • When you use the BizTalk Server Accelerator for HL7 v1.3 in Microsoft BizTalk Server 2006, HL7 schemas are uniquely identified by their namespace. The HL7 parser checks the party configuration for each HL7 message.
  • When this problem occurs, valid HL7 messages can be processed correctly. Additionally, the ACKs are not sent back to the source application as expected. Therefore, if BizTalk Server receives invalid HL7 messages, validation errors will be included in the event logs, and the message will be suspended.

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Cause

This problem occurs because of an error in the BizTalk Accelerator for HL7.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.solutions.btahl7.hl72fasm.dll1.3.1123.059,25631-Aug-200902:25x86
Microsoft.solutions.btahl7.hl7wizard.dll1.3.1103.060,16031-Aug-200902:25x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the HL7 v2 Developer Guide, visit the following Microsoft Developer Network (MSDN) Web site:

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB974836, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbbiztalk2006presp1fix, kbautohotfix, kbbtsaccelerators

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Article Info
Article ID : 974836
Revision : 1
Created on : 9/16/2009
Published on : 9/16/2009
Exists online : False
Views : 324