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Integrated device drivers do not work after you log on to a system that was prepared by using the Sysprep.exe utility in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You install an integrated device driver without connecting the device to the computer.
  • The .inf files for the integrated device driver use directory identifiers (dirids). The values of the dirids are between 16384 and 32767.
  • You run the Sysprep.exe utility together with the /generalize option to prepare a Windows installation.
  • You log on to the prepared system.
In this scenario, the driver does not work correctly.

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Cause

This problem occurs because the dirids are not expanded correctly. This causes the integrated device driver to work incorrectly.

For example, an entry in one of the .inf files uses the following syntax:
MyBinary = %16422%\MyFile.sys
When you log on to the prepared system, you expect that the path in the example is expanded to the following:
C:\Program Files\MyFile.sys
However, the actual result is as follows:
\MyFile.sys

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows 7 or Windows Server 2008 R2.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both of these operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Drvstore.dll6.1.7600.20530318,97618-Sep-200904:59x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Drvstore.dll6.1.7600.20530418,30418-Sep-200906:27x64
Drvstore.dll6.1.7600.20530318,97618-Sep-200904:59x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Drvstore.dll6.1.7600.20530732,67218-Sep-200904:35IA-64
Drvstore.dll6.1.7600.20530318,97618-Sep-200904:59x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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References

For more information about dirids, visit the following Microsoft TechNet Web site:

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Keywords: kbautohotfix, kbfix, kbqfe, kbexpertiseadvanced, kbsurveynew, kbhotfixserver, KB974624

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Article Info
Article ID : 974624
Revision : 2
Created on : 12/22/2009
Published on : 12/22/2009
Exists online : False
Views : 259