Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Task Scheduler MMC snap-in stops responding when you view the history tab of a task that has more than 10,000 history events on a computer that is running Windows Server 2008 or Windows Vista


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 or Windows Vista.
  • The event history for a scheduled task is larger than approximately 10,000 events.
In this scenario, when you view the history tab, the Task Scheduler Microsoft Management Console (MMC) snap-in stops responding.

↑ Back to the top


Cause

The issue occurs because of a deadlock situation in the Task Scheduler MMC snap-in.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6001.224983,375,10417-Aug-200913:43x86
For all supported x86-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.222013,375,10417-Aug-200913:08x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6001.224983,375,10417-Aug-200913:43x86
For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.222013,375,10417-Aug-200913:08x86
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6001.224983,375,10417-Aug-200913:43x86
For all supported Itanium-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.222013,375,10417-Aug-200913:08x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Msil_miguicontrols_31bf3856ad364e35_6.0.6001.22498_none_ae792e0f55fa707d.manifestNot Applicable3,76417-Aug-200914:24Not Applicable
Msil_miguicontrols_31bf3856ad364e35_6.0.6002.22201_none_b0b9ef2352de15ee.manifestNot Applicable3,76417-Aug-200913:40Not Applicable
Package_for_kb974589_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36718-Aug-200905:40Not Applicable
Package_for_kb974589_client_2~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53018-Aug-200905:40Not Applicable
Package_for_kb974589_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71218-Aug-200905:40Not Applicable
Package_for_kb974589_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42518-Aug-200905:40Not Applicable
Package_for_kb974589_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53018-Aug-200905:40Not Applicable
Package_for_kb974589_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71318-Aug-200905:40Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista

File nameFile versionFile sizeDateTimePlatform
Msil_miguicontrols_31bf3856ad364e35_6.0.6001.22498_none_ae792e0f55fa707d.manifestNot Applicable3,76417-Aug-200914:24Not Applicable
Msil_miguicontrols_31bf3856ad364e35_6.0.6002.22201_none_b0b9ef2352de15ee.manifestNot Applicable3,76417-Aug-200913:40Not Applicable
Package_for_kb974589_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37518-Aug-200905:40Not Applicable
Package_for_kb974589_client_2~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54018-Aug-200905:40Not Applicable
Package_for_kb974589_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72218-Aug-200905:40Not Applicable
Package_for_kb974589_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43318-Aug-200905:40Not Applicable
Package_for_kb974589_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54018-Aug-200905:40Not Applicable
Package_for_kb974589_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72318-Aug-200905:40Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Msil_miguicontrols_31bf3856ad364e35_6.0.6001.22498_none_ae792e0f55fa707d.manifestNot Applicable3,76417-Aug-200914:24Not Applicable
Msil_miguicontrols_31bf3856ad364e35_6.0.6002.22201_none_b0b9ef2352de15ee.manifestNot Applicable3,76417-Aug-200913:40Not Applicable
Package_for_kb974589_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42918-Aug-200905:40Not Applicable
Package_for_kb974589_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,37018-Aug-200905:40Not Applicable
Package_for_kb974589_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71618-Aug-200905:40Not Applicable

↑ Back to the top


Keywords: kbhotfixserver, kbautohotfix, kbexpertiseadvanced, kbqfe, kbsurveynew, KB974589

↑ Back to the top

Article Info
Article ID : 974589
Revision : 1
Created on : 10/19/2009
Published on : 10/19/2009
Exists online : False
Views : 315