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The child process of a console application may exit together with the error code 128 after you install the security update 958690 (MS09-006) on a computer that is running Windows Server 2003 SP2 or Windows XP Professional x64 Edition SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2) or Windows XP Professional x64 Edition Service Pack 2 (SP2).
  • You apply at least one of the following updates to the computer:
    • Security update 958690 (MS09-006).
    • A Windows update that updates the system file Multiuser Win32 Driver (Win32k.sys) to a newer version that is comparable to the version of the Win32k.sys file in the security update 958690 (MS09-006).
  • You have an application that meets the following requirements on the computer:
    • The application is a console application.
    • The application does not display an interactive window.
    • The application runs under an account other than the current user account.
In this scenario, the child process of this application may exit. Additionally, you receive the error code 128.

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Cause

This issue occurs after you apply the security update 958690 (MS09-006). When the child process tries to start, the child process tries to open a desktop handle. Then the child process can be launched under a desktop. However, the desktop handle is null. Therefore, the child process exits together with the error code 128.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 (SP2) installed.

For more information about how to install the Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP and Windows Server 2003 file information note
  • The files that apply to a specific milestone (RTM, SPn) are noted in the "SP requirement" column.
  • In addition to the files that are listed in these tables, this software update also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.45691,851,39211-Aug-200912:53x86
For all supported x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.45694,534,27211-Aug-200919:41x64
For all supported Itanium-based versions of Windows Server 2003
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.2.3790.45695,571,07211-Aug-200919:41IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
960266 Error message when you call the CreateProcess function to start a process of a console application by using an account other than the current logon account in Windows Server 2003: "The application failed to initialize properly (0xc0000142)"
958690 MS09-006: Vulnerabilities in Windows Kernel could allow remote code execution

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Keywords: kbfix, kbautohotfix, kbexpertiseadvanced, kbsurveynew, kbqfe, KB974509

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Article Info
Article ID : 974509
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 405