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FIX: You cannot disapprove a campaign or a campaign item in Marketing Manager in Commerce Server 2007 or Commerce Server 2009


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Microsoft Commerce Server on two or more computers. The computers are set up to use different timezones.
  • You create and then approve a marketing campaign or a marketing campaign item. For example, an advertisement, a discount, or direct mail.
  • You host the campaign or the campaign item on one computer.
  • From another computer that is set up to use a timezone that is farther west than the computer that is hosting the campaign or the campaign item, you use Marketing Manager to disapprove the campaign or the campaign item.
In this scenario, the disapprove operation fails. Additionally, errors that resemble the following are logged in the Application event logs on both the Marketing Manager client side and on the Marketing Service host side.

Event on the Marketing Manager client side:

Event Type: Error
Event Source: Commerce Server Business UI
Event Category: None
Event ID: 101
Description: Microsoft.CommerceServer.ServerFaultException: SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 PM.

Event on the Marketing Service host side:

Event Type: Error
Event Source: Commerce Server Web Services
Event Category: None Event ID: 2
Description: An exception occurred in the 'MarketingWebService' Web service. Exception details follow:

System.Data.SqlTypes.SqlTypeException: SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 PM.

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Cause

This problem occurs because of an error in the marketing system of Commerce Server.

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Resolution

To resolve this problem, you must apply this hotfix on all Web servers that are hosting the Commerce Server Web Services.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) installed to apply the hotfix for Commerce Server 2007. You must have Commerce Server 2009 installed to apply the hotfix for Commerce Server 2009.

Restart requirement

You do not have to restart your computer. However, you must restart Internet Information Services (IIS) after you apply this hotfix. To restart IIS, at a command prompt, type the following command, and then press ENTER:
IISRESET /RESTART
Note This command stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Commerce Server 2007
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerceserver.marketing.datamanagement.dll6.0.4109.22518,04005-Aug-200914:49x86
Commerce Server 2009
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerceserver.marketing.datamanagement.dll6.0.4171.6518,05610-Sep-200913:53x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to manage your marketing campaigns, visit the following Microsoft Web site:

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Keywords: KB974321, kbsurveynew, kbqfe, kbexpertiseadvanced, kbautohotfix, kbhotfixserver

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Article Info
Article ID : 974321
Revision : 2
Created on : 9/16/2009
Published on : 9/16/2009
Exists online : False
Views : 526