Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When you open Add or Remove Programs on a computer that is connected to one or more large hard disks, Add or Remove Programs seems to stop responding in Windows XP or in Windows Server 2003


View products that this article applies to.

Symptoms

You have a computer that is running Windows XP or Windows Server 2003. The computer is connected to one or more large hard disks. For example, the computer is connected to one or more 8-terabyte (TB) disks. The disks are local physical disks, or the disks reside on a storage area network (SAN). When you open the Add or Remove Programs item in Control Panel, Add or Remove Programs seems to stops responding. You receive the following message in Add or Remove Programs:
Please wait while the list is being populated
This issue does not occur if the computer is not connected to large hard disks.

↑ Back to the top


Cause

When you open Add or Remove Programs, Windows scans the files in the first level of the folders on all disks that connect to the computer. Windows performs this scan operation to retrieve the information about installed programs. Large hard disks usually contain many files and folders. Therefore, the scan operation takes a long time to finish.

↑ Back to the top


Status

This behavior is by design.

↑ Back to the top


Keywords: kbnosurvey, kbarchive, kbexpertiseadvanced, kbsurveynew, kbtshoot, kbprb, KB974172

↑ Back to the top

Article Info
Article ID : 974172
Revision : 2
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 309