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Network policies on a computer that is running Windows Server 2008 do not work when a format that uses a comma as the decimal separator is specified in Regional and Language Options


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Network Policy Server role service on a server that is running Windows Server 2008.
  • In the Regional and Language Options dialog box, a language that uses a comma (,) as the decimal separator is specified. For example, you specify the format as Dutch (Belgium).

    Note
    For a complete list of formats that are affected by this problem, see the "More information" section.
  • You add an operating system condition to a network policy in the Network Policy Server snap-in.
  • You specify a version requirement for operating systems in the condition. For example, you specify that the operating system number is less than 00006,10000.
In this scenario, you notice that the version number is reset to 0.0. Additionally, the network policy does not check the version of the operating system.

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Cause

This problem occurs because the Network Policy Server snap-in always uses a period (.) as the decimal separator in the version number, regardless of the format that you set in the Regional and Language Options dialog box.

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Resolution

To resolve this problem, install this hotfix on all servers that have the Network Policy Server role service installed. After you install this hotfix, the Network Policy Server snap-in examines the system format setting to use the correct decimal separator.
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table.

Windows Vista and Windows Server 2008 file information notes

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 18xxxWindows Server 2008SP1GDR
    6.0.600 1 . 22xxxWindows Server 2008SP1LDR
    6.0.600 2 . 18xxxWindows Server 2008SP2GDR
    6.0.600 2 . 22xxxWindows Server 2008SP2LDR
  • The first release of Windows Server 2008 contains Service Pack ( SP1)
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately . MUM and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Npsui.dll6.0.6002.222173,657,72802-Sep-200918:50x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Npsui.dll6.0.6002.222173,657,72802-Sep-200918:42x86

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Workaround

To work around this problem, follow these steps:
  1. Specify a format that uses a period (.) as the decimal separator before you create a network policy. For example, you specify the format as English (United States).
  2. After you create the network policy, revert to the original format.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The following formats are affected by this problem:
  • Albanian (Albania)
  • Basque (Basque)
  • Bosnian (Cyrillic, Bosnia, and Herzegovina)
  • Bosnian (Latin, Bosnia, and Herzegovina)
  • Croatian (Croatia)
  • Croatian (Latin, Bosnia, and Herzegovina)
  • Danish (Denmark)
  • Dutch (Belgium)
  • Dutch (Netherlands)
  • Faroese (Faroe Islands)
  • French (Belgium)
  • Frisian (Netherlands)
  • Galician (Galician)
  • German (Austria)
  • German (Germany)
  • German (Luxembourg)
  • Greek (Greece)
  • Icelandic (Iceland)
  • Indonesian (Indonesia)
  • isiXhosa (South Africa)
  • Italian (Italy)
  • Lithuanian (Lithuania)
  • Lower Sorbian (Germany)
  • Macedonian (Former Yugoslav Republic of Macedonia)
  • Malay (Brunei Darussalam)
  • Mapudungun (Chile)
  • Portuguese (Brazil)
  • Portuguese (Portugal)
  • Quechua (Bolivia)
  • Quechua (Ecuador)
  • Romanian (Romania)
  • Serbian (Cyrillic, Bosnia, and Herzegovina)
  • Serbian (Cyrillic, Serbia)
  • Serbian (Latin, Bosnia, and Herzegovina)
  • Serbian (Latin, Serbia)
  • Slovenian (Slovenia)
  • Spanish (Argentina)
  • Spanish (Bolivia)
  • Spanish (Chile)
  • Spanish (Colombia)
  • Spanish (Costa Rica)
  • Spanish (Ecuador)
  • Spanish (Paraguay)
  • Spanish (Spain)
  • Spanish (Uruguay)
  • Spanish (Venezuela)
  • Tamazight (Latin, Algeria)
  • Turkish (Turkey)
  • Upper Sorbian (Germany)
  • Vietnamese (Vietnam)
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional File information

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Msil_npsui_31bf3856ad364e35_6.0.6002.22217_none_9aba06846beaf777.manifestNot applicable2,74802-Sep-200919:17Not applicable
Package_for_kb974126_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,36403-Sep-200900:17Not applicable
Package_for_kb974126_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot applicable1,43003-Sep-200900:17Not applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Msil_npsui_31bf3856ad364e35_6.0.6002.22217_none_9aba06846beaf777.manifestNot applicable2,75002-Sep-200919:07Not applicable
Package_for_kb974126_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,37203-Sep-200900:17Not applicable
Package_for_kb974126_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,43803-Sep-200900:17Not applicable

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Keywords: KB974126, kbfix, kbqfe, kbautohotfix, kbhotfixserver, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 974126
Revision : 2
Created on : 11/6/2009
Published on : 11/6/2009
Exists online : False
Views : 208