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You cannot restore large files in the NTFS file system when all the data streams that have sparse attributes are deleted in the 64-bit version of Windows XP SP2 or in Windows Server 2003 SP2


View products that this article applies to.

Symptoms

When you restore large data files in an NTFS file system on a computer that is running Windows XP x64-bit version Service Pack 2 (SP2) or Windows Server 2003 Service Pack 2 (SP2), the restore operation fails. Additionally, the data in the data files is lost. When this problem occurs, the following event is displayed in the System log:

Event Type: Warning
Event Source: Ntfs
Event Category: None
Event ID: 50
Computer: <Computer name>
Description: {Delayed Write Failed} Windows was unable to save all the data for the file. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.
Additionally, the following event is logged in the Application log:

Event ID: 26
Category: None
Source: Application Popup
Type: Information
Machine : <Computer name>
Message: Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file <file name> The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

Note This issue occurs when all the following conditions are true:
  1. All the sparse data streams of the file are removed.
  2. The sparse attribute of the file is not removed.
  3. The left sparse attribute information is large enough to exceed the restoring limitation of the NTFS file system.

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Cause

This problem occurs because the sparse attribute of a file remains on an NTFS file system after you delete all data streams that have a sparse attribute from the file.

NTFS supports additional named data streams. When an additional named data stream that has a sparse attribute is added to a file, the sparse attribute is also set for the file. However, if you remove all the data streams that have a sparse attribute from the file, the sparse attribute for the file remains. Therefore, when you perform a back-up process and then restore the file, the restored file is displayed as a sparse file. This behavior occurs even if the file does not have data streams that with sparse attributes.

When you restore the sparse file, NTFS handles the file as a fragmented file. If the sparse file size is too large, then the system resources will be insufficient to complete the restore operation. This issue occurs because the sparse attribute of a file remains on the NTFS file system after you delete all data streams that have a sparse attribute from the file.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows XP x64-bit version Service Pack 2 (SP2)
  • Windows Server 2003 Service Pack 2 (SP2)
For more information about how to install the latest Windows XP service pack, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

For more information about how to install the latest Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Instructions to resolve the issue

To resolve this issue, follow these steps:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
  1. Download and then install the hotfix package.
  2. Start Registry Editor. To do this, click Start, click Run, type regedit, and then click OK.
  3. Locate and then select the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
  4. On the Edit menu, point to New , and then click DWORD Value .
  5. Type NtfsResetFileSparseAttributeOnDeletingLastSparseStream, and then press the Enter Key.
  6. Right-click NtfsResetFileSparseAttributeOnDeletingLastSparseStream, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. Exit Registry Editor.
Note After you install this hotfix package, and then configure the NtfsResetFileSparseAttributeOnDeletingLastSparseStream registry entry, you have to restart the computer to enable this hotfix on the NFTS file system.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP and Windows Server 2003 file information notes

  • In addition to the files that are listed in these tables, this software update also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.

For all supported x64-based versions of Windows XP SP 2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.45701,047,55213-Aug-200904:27x64

For all supported x86-based versions of Windows Server 2003 SP 2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4570593,40812-Aug-200912:57x86

For all supported x64-based versions of Windows Server 2003 SP 2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.45701,047,55213-Aug-200904:27x64

For all supported Itanium-based versions of Windows Server 2003 SP 2

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.45701,894,40013-Aug-200904:26IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around the issue, you can copy the files instead of backing up the files. Then you can restore the files by using backup software.

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Keywords: kbfix, kbautohotfix, kbexpertiseadvanced, kbsurveynew, kbqfe, kbhotfixserver, KB973886

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Article Info
Article ID : 973886
Revision : 1
Created on : 10/14/2009
Published on : 10/14/2009
Exists online : False
Views : 212