Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Fax Service crashes when a fax server receives a fax on a computer that is running Windows Server 2008 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Fax Server role on a computer that is running Windows Server 2008 or Windows Server 2008 R2 .
  • You configure the Fax Server role to route incoming faxes to an e-mail address.
In this scenario, the Fax Service may crash when a fax arrives. Additionally, the sender of the fax receives a notification that the fax is sent successfully. However, the fax is not routed to the specified e-mail address.

Also, the following events are logged in the Application log:

Event ID 32089
Event ID 32083
NoteThis problem is not specific to the Fax Server role on a computer that is running Windows Server 2008 or Windows Server 2008 R2. This problem can occur when any application or service makes some Collaboration Data Objects (CDO) calls to the Inetcomm.dll module on a computer that is running Windows Vista, Windows Server 2008, Windows 7 or Windows Server 2008 R2.

↑ Back to the top


Cause

The Fax Server role makes some CDO calls to the Inetcomm.dll module to route a fax to an e-mail address. Every time that a fax is routed, the Inetcomm.dll module is loaded and then unloaded.

However, two classes are not unregistered when this module is unloaded. If the module is reloaded at a different address, some WndProc function calls still point to the old address. In this situation, an exception occurs because the old address is invalid. This exception causes the Fax Service to crash.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information note
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the fileversion numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    0.
    20xxx
    Windows VistaRTMLDR
    6.0.600
    1.
    22xxx
    Windows Vista and Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the original release of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum)that are installed for each environment are listed separately. MUM and MANIFEST files, andthe associated security catalog (.cat) files, are critical to maintaining thestate of the updated component. The security catalog files (attributes notlisted) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.0.6001.22473738,30416-Jul-200916:18x86
Inetres.dll6.0.6001.2247384,48016-Jul-200914:17x86
Inetcomm.dll6.0.6002.22175738,81616-Jul-200916:16x86
Inetres.dll6.0.6002.2217584,48016-Jul-200914:06x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.0.6001.22473974,84816-Jul-200916:40x64
Inetres.dll6.0.6001.2247384,48016-Jul-200914:43x64
Inetcomm.dll6.0.6002.22175974,84816-Jul-200916:16x64
Inetres.dll6.0.6002.2217584,48016-Jul-200914:19x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.0.6001.224732,330,11216-Jul-200916:23IA-64
Inetres.dll6.0.6001.2247384,48016-Jul-200914:38IA-64
Inetcomm.dll6.0.6002.221752,330,11216-Jul-200916:06IA-64
Inetres.dll6.0.6002.2217584,48016-Jul-200914:17IA-64
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.21xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.1.7600.20879740,86413-Jan-201105:39x86
Inetcomm.dll6.1.7601.21640741,88813-Jan-201105:35x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.1.7600.20879976,89613-Jan-201106:18x64
Inetcomm.dll6.1.7601.21640976,89613-Jan-201106:22x64
Inetcomm.dll6.1.7600.20879740,86413-Jan-201105:39x86
Inetcomm.dll6.1.7601.21640741,88813-Jan-201105:35x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Inetcomm.dll6.1.7600.208792,332,67213-Jan-201105:24IA-64
Inetcomm.dll6.1.7601.216402,332,67213-Jan-201105:12IA-64
Inetcomm.dll6.1.7600.20879740,86413-Jan-201105:39x86
Inetcomm.dll6.1.7601.21640741,88813-Jan-201105:35x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
X86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6001.22473_none_79f21e5171e04b44.manifestNot Applicable148,16416-Jul-200917:57Not Applicable
X86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6002.22175_none_7bda90cd6f04d316.manifestNot Applicable148,16416-Jul-200917:36Not Applicable
Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6001.22473_none_d610b9d52a3dbc7a.manifestNot Applicable148,22416-Jul-200918:20Not Applicable
Amd64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6002.22175_none_d7f92c512762444c.manifestNot Applicable148,22416-Jul-200917:35Not Applicable
Additional files for all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6001.22473_none_79f3c24771de5440.manifestNot Applicable148,19416-Jul-200920:02Not Applicable
Ia64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.0.6002.22175_none_7bdc34c36f02dc12.manifestNot Applicable148,19416-Jul-200917:18Not Applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,625
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7600.20879_none_7a1ff604d2f217ab.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:44
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7601.21640_none_7c1dc034d0084bb5.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:44
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7600.20879_none_d63e91888b4f88e1.manifest
File versionNot Applicable
File size58,396
Date (UTC)13-Jan-2011
Time (UTC)20:47
PlatformNot Applicable
File nameAmd64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7601.21640_none_d83c5bb88865bceb.manifest
File versionNot Applicable
File size58,396
Date (UTC)13-Jan-2011
Time (UTC)20:47
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,645
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7600.20879_none_7a1ff604d2f217ab.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:47
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7601.21640_none_7c1dc034d0084bb5.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:47
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7600.20879_none_7a2199fad2f020a7.manifest
File versionNot Applicable
File size58,394
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameIa64_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7601.21640_none_7c1f642ad00654b1.manifest
File versionNot Applicable
File size58,394
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,939
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7600.20879_none_7a1ff604d2f217ab.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable
File nameX86_microsoft-windows-mail-comm-dll_31bf3856ad364e35_6.1.7601.21640_none_7c1dc034d0084bb5.manifest
File versionNot Applicable
File size58,392
Date (UTC)13-Jan-2011
Time (UTC)20:42
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbhotfixserver, kbqfe

↑ Back to the top

Article Info
Article ID : 973640
Revision : 3
Created on : 9/20/2018
Published on : 9/21/2018
Exists online : False
Views : 435