Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot fail over disk resources on a passive cluster node if you call the DefragAnalysis method of the "Win32_Volume" WMI Class


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run a script that calls the DefragAnalysis method of the Win32_Volume WMI Class on a computer that is running Windows Server 2003. This script runs on a passive cluster node.
  • You cannot access the disk resources on the passive cluster node. This lack of access causes the script to fail.
  • You try to fail over the disk resources to the passive cluster node after the script fails.
In this scenario, the failover fails.

↑ Back to the top


Cause

This problem occurs because the WMI Provider Host (Wmiprvse.exe) process that hosts the Vdswmi.dll module leaks a handle in the scenario that is mentioned in the "Symptoms" section. The handle leak prevents the failover of the disk resources.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Vdswmi.dll5.2.3790.4552134,65616-Jul-200910:14x86
For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Vdswmi.dll5.2.3790.4552466,43216-Jul-200911:51IA-64
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Vdswmi.dll5.2.3790.4552294,91216-Jul-200911:50x64

↑ Back to the top


Workaround

To work around the issue, use one of the following methods:

Method 1

Modify the script to check only local disk drives.

Method 2

Terminate the Wmiprvse.exe process that hosts the Vdswmi.dll module. To identify the process ID of the Wmiprvse.exe process that is hosting the Vdswmi.dll module, run the following command:
tasklist /M vdswmi.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the DefragAnalysis method of the Win32_Volume WMI Class, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB973597

↑ Back to the top

Article Info
Article ID : 973597
Revision : 1
Created on : 8/18/2009
Published on : 8/18/2009
Exists online : False
Views : 269