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You cannot print a page and you receive an error message in an application that hosts a WebOC that uses a custom print template in Internet Explorer 8


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Symptoms

Consider the following scenario:
  • On a computer that has Windows Internet Explorer 8 installed, you run an application.
  • The application hosts a Web Object Control (WebOC) that uses custom print templates in Windows Internet Explorer.
  • You previously used the OLECMDEXECOPT_DONTPROMPTUSER option in the source code to disable the Print dialog box.
  • You use the application to print a page by using a custom print template.
In this scenario, the page is not printed. Also, you receive a script error message in the printer.printpage line of the source code.

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Cause

This issue occurs in a WebOC application in Internet Explorer 8 because the print dialog box element cannot locate the page that should be printed.

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Resolution

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To install the most current updates, visit the following Microsoft Web site:
For more technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site:
Note This update was first included in security update 978207 (MS10-002). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
978207� MS10-002: Cumulative security update for Internet Explorer

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More information

Steps to reproduce the problem

  1. Download the Printtemplates.exe sample application, and then run the application. To download this application, visit the following Microsoft Web site:
  2. On the drop-down menu next to Template Source, select template 2.
  3. Click Print w/o Prompt.
Template 2 is not printed, and you receive the following script error message:
Line: 95

Char: 2

Error: Unspecified error.

Code: 0

URl: res://printtemplates.exe/sampledesc.htm

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Keywords: KB973538, kbprb, kbsurveynew, kbhotfixserver, kbqfe, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 973538
Revision : 3
Created on : 10/22/2009
Published on : 10/22/2009
Exists online : False
Views : 323