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Text takes a long time to appear on the screen when you type inside a TEXTAREA element in a Web page in Internet Explorer 8 Standards mode


View products that this article applies to.

Symptoms

Consider the following scenario. You view a webpage in Windows Internet Explorer 8 Standards mode. The webpage contains a TEXTAREA element and some SELECT elements. These SELECT elements are displayed as drop-down lists that contain multiple options.

In this scenario, when you type inside the TEXTAREA element, the appearance of the text on the screen is delayed.

Note This issue does not occur in other document modes in Internet Explorer 8.

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Cause

This issue occurs because Internet Explorer 8 continually recalculates the number of options in the SELECT elements. This process uses system resources and delays response to user input.

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Workaround

To work around this issue, put the TEXTAREA element inside a DIV element that is separate from the drop-down lists. You must be a Web server administrator to implement this workaround.

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Resolution

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To install the most current updates, visit the following Microsoft website:
For more technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft website:
Note This update was first included in security update 978207 (MS10-002). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
978207 MS10-002: Cumulative security update for Internet Explorer

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To install this hotfix, you must have Internet Explorer 8 installed on a computer that is running one of the following operating systems:
  • Windows XP Service Pack 2 (SP2) or Windows XP Service Pack 3 (SP3)
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows Vista
  • Windows Server 2008

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Internet Explorer 8 for Windows XP SP2 and for Windows XP SP3
File nameFile versionFile sizeDateTimePlatformSP requirement
Ieframe.dll8.0.6001.2290411,069,44029-Jul-200905:23x86SP3
Mshtml.dll8.0.6001.229045,938,68829-Jul-200905:23x86SP3
For all supported x86-based versions of Internet Explorer 8 for Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Ieframe.dll8.0.6001.2290411,069,44029-Jul-200906:07x86SP2
Mshtml.dll8.0.6001.229045,938,68829-Jul-200906:07x86SP2
For all supported x86-based versions of Internet Explorer 8 for Windows Vista and for Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll8.0.6001.229045,938,68825-Jul-200915:39x86
Mshtml.tlb8.0.6001.229041,638,91225-Jul-200914:05Not Applicable
Ieframe.dll8.0.6001.2290411,069,44025-Jul-200915:38x86
Ieui.dll8.0.6001.22904164,35225-Jul-200915:38x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about TEXTAREA elements, visit the following Microsoft website:For more information about how to use Developer Tools to test browser mode and to test document mode, visit the following Microsoft website:For more information about document compatibility in Internet Explorer 8, visit the following Microsoft website:For more information about SELECT elements, visit the following Microsoft website:

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Keywords: KB973533, kbprb, kbsurveynew, kbhotfixserver, kbqfe, kbexpertiseinter

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Article Info
Article ID : 973533
Revision : 1
Created on : 5/4/2011
Published on : 5/4/2011
Exists online : False
Views : 395