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A .NET Framework application crashes in the CLR version 4 on a computer that is running an Itanium-based version of Windows Server 2003 SP2 or of Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You develop a .NET Framework application in the common language runtime (CLR) version 4 environment.
  • You run this application on a computer that is running an Itanium-based version of Windows Server 2003 Service Pack 2 (SP2) or of Windows Server 2008.
  • This application encounters an exception that is expected to be handled by the application itself.
However, the application does not handle the exception and crashes.

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Cause

This issue occurs because of an error in the Itanium-based exception handling code. Therefore, the .NET Framework application is incorrectly terminated.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported Itanium-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.45581,646,59223-Jul-200905:51IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.45586,580,73623-Jul-200905:51IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4558775,16823-Jul-200905:51x86SP2WOW

Hotfix information for Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll6.0.6001.224752,562,14418-Jul-200911:53IA-64SP1Not Applicable
Ntoskrnl.exe6.0.6001.224759,483,84818-Jul-200921:25IA-64SP1Not Applicable
Ntdll.dll6.0.6001.224751,165,10418-Jul-200911:56x86SP1WOW
Ntdll.dll6.0.6002.221802,562,63218-Jul-200911:43IA-64SP2Not Applicable
Ntoskrnl.exe6.0.6002.221809,461,83218-Jul-200912:11IA-64SP2Not Applicable
Ntdll.dll6.0.6002.221801,165,08018-Jul-200911:47x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the RtlUnwindEx function, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB973476, kbqfe, kbsurveynew, kbfix, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 973476
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 283