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A multiprocessor computer that is running Windows Server 2003 SP2 stops responding under a heavy load if you change a Windows Firewall setting


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a multiprocessor computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • You change one or more Windows Firewall settings on the computer.
Under a heavy load, the computer may stop responding, or the computer may encounter one of the following Stop error codes:
  • 0x000000C2 BAD_POOL_CALLER
  • 0x000000CC PAGE_FAULT_IN_FREED_SPECIAL_POOL
  • 0x000000D5 DRIVER_PAGE_FAULT_IN_FREED_SPECIAL_POOL

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Cause

This problem occurs because of a timing issue in Windows Firewall. The timing issue occurs when two threads try to delete the same mapping entry concurrently. To delete the mapping entry, a thread must perform the following two steps:
  1. The thread sets a deletion flag on this mapping entry.
  2. The thread deletes the mapping entry.
Under certain circumstances, a thread may incorrectly delete a mapping entry while another thread finishes step 1. Therefore, this other thread tries to access the freed memory space when it performs step 2. This behavior causes the system to trigger a Stop error code, or the behavior may cause the computer to stop responding.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.4554119,80817-Jul-200912:20x86
For all supported Itanium-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.4554384,00018-Jul-200903:56IA-64
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.4554181,24818-Jul-200903:56x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB973295

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Article Info
Article ID : 973295
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 250