Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Ntbackup.exe program crashes when the Ntbackup.exe program exits on a computer that is running Windows Server 2003


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003, when the Ntbackup.exe program exits, the Ntbackup.exe program may encounter an access violation issue, and then the Ntbackup.exe program crashes.

When this issue occurs, the Ntbackup.exe program displays a message. Therefore, if a script task uses the Ntbackup.exe program and this issue is encountered, you have to close the message manually to continue the script task.

↑ Back to the top


Cause

This issue occurs because of a timing issue between the main thread and a worker thread. When the timing issue occurs, a thread frees memory space that is pointed to by a pointer but the pointer is not set to NULL. However, another thread tries to free the memory space again, and this other thread generates an access violation exception.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntbackup.exe5.2.3790.45511,229,31214-Jul-200910:08x86SP2
W03a3409.dll5.2.3790.454643,00808-Jul-200912:25x86SP2
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.45511,966,59215-Jul-200901:29x64SP2Not Applicable
W03a3409.dll5.2.3790.454643,52015-Jul-200901:29x64SP2Not Applicable
Ww03a3409.dll5.2.3790.454643,00815-Jul-200901:29x86SP2WOW
For all supported Itanium-based versions of Windows Server 2003 SP 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntbackup.exe5.2.3790.45511,966,59215-Jul-200901:29x64SP2Not Applicable
W03a3409.dll5.2.3790.454643,52015-Jul-200901:29x64SP2Not Applicable
Ww03a3409.dll5.2.3790.454643,00815-Jul-200901:29x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB973125

↑ Back to the top

Article Info
Article ID : 973125
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 308