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Duplicate computer names are generated when you configure an Unattend.xml file to generate random names for many computers on a network


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are deploying operating systems such as Windows Vista or Windows Server 2008 to many computers on a network.
  • You configure an Unattend.xml file to generate random names for these computers.
In this scenario, duplicate computer names may be generated.

Note The hotfix discussed in Microsoft Knowledge Base (KB) article 970485 partly fixes this problem. The hotfix mentioned in this article discusses a second part of this problem.

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Cause

This issue occurs because of an error in the algorithm that is used to generate the random computer name.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Restart requirement

You do not have to restart the computer after you install the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Instructions to apply the hotfix package

Use the following procedures to apply the hotfix package.

Update each image in the Install.wim image file

  1. Install the Windows OEM Preinstallation Kit (Windows OPK) or the Windows Automated Installation Kit (Windows AIK).
  2. Use either of the following methods to apply the hotfix package to the Windows image that you are deploying:
    • Double-click the Microsoft Update stand-alone Package (MSU) file on a computer that is running Windows Vista to install the hotfix package.
    • To install the hotfix package offline, use the instructions that are included in the Windows OPK or in the Windows AIK. To do this, see the following topics in the OPK.chm file or in the WAIK.chm file:
      • Windows Preinstallation Phases \ Phase 5: Image Maintenance \ Servicing an Image
      • Windows Preinstallation Phases \ Phase 5: Image Maintenance \ Maintenance Walkthroughs \ Walkthrough: Servicing a Windows Image Offline
  3. Copy the updated Install.wim file to Installation_Point \sources, where Installation_Point is the location of the contents of the Windows Setup media.

Update a Setup binary in image 2 of the Boot.wim file

  1. Expand the MSU file (Windows6.0 KB973033 Arch.msu) for the architecture that is being serviced to a temporary folder. For example, at the command prompt, type the following command and then press ENTER:
    Expand.exe Path_To_MSU_File F:* Path_To_TemporaryFolder1
  2. Expand the CAB file (Windows6.0 KB973033 Arch.cab) from the previously created temporary folder to another temporary folder. For example, at the command prompt, type the following command and then press ENTER:
    Expand.exe Path_To_CAB_File F:* Path_To_TemporaryFolder2
    Note In Windows XP or in Windows Server 2003, this command may generate an error. If you receive an error message, use the version of the Expand.exe tool that is included in the Windows OPK or in the Windows AIK to extract the files.
  3. Copy the Boot.wim file from the Sources folder of the Windows Vista installation media to a local temporary folder.
  4. Mount the "Microsoft Windows Longhorn Setup" image (index 2) of the Boot.wim file that uses Read/Write permission. For example, at the command prompt, type the following command and then press ENTER:
    imagex.exe /mountrw Path_To_Boot_WIM_File 2 Mount_Location
  5. Copy the following files from the " Path_To_TemporaryFolder2 \x86_microsoft windows setup component" folder that you created in step 2 to the Mount_Location \Sources folder:
    • Actionqueue.dll
    • Diager.dll
    • Diagnostic.dll
    • Setup.exe
    • Spprgrss.dll
    • W32uiimg.dll
    • W32uires.dll
    • Wdsutil.dll
    • Win32ui.dll
    • Winsetup.dll
  6. Unmount the Boot.wim file, and then commit all changes. For example, at the command prompt, type the following command and then press ENTER:
    imagex.exe /commit /unmount Mount_Location
  7. Copy the changed Boot.wim file to the Installation_Point \Sources folder.

    NoteInstallation_Point is the location of the contents of the Windows Setup media.
  8. Delete all temporary folders.

Update a Setup binary that exists on installation media that does not use a Windows Image Format (WIM) file

  1. Expand the MSU file (Windows6.0 KB973033 arch.msu) for the architecture that is being serviced to a temporary folder. For example, at the command prompt, type the following command and then press ENTER:
    Expand.exe Path_To_MSU_File F:* Path_To_TemporaryFolder1
  2. Expand the CAB file (Windows6.0 KB973033 arch.cab) from the previously created temporary folder to another temporary folder. For example, at the command prompt, type the following command and then press ENTER:
    Expand.exe Path_To_CAB_File F:* Path_To_TemporaryFolder2
    Note In Windows XP or in Windows Server 2003, this command may generate an error. If you receive an error message, use the version of the Expand.exe tool that is included in the Windows OPK or in the Windows AIK to extract the files
  3. Copy the following files from the " Path_To_TemporaryFolder2 \x86_microsoft windows setup component" folder that you created in step 2 to the Installation_Point \Sources folder:
    • Actionqueue.dll
    • Diager.dll
    • Diagnostic.dll
    • Setup.exe
    • Spprgrss.dll
    • W32uiimg.dll
    • W32uires.dll
    • Wdsutil.dll
    • Win32ui.dll
    • Winsetup.dll
    Note Do not copy any other files over onto the installation point even if the files have the same name. If you do this, Windows Setup may behave unpredictably.
  4. Delete all temporary folders.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately . MUM and MANIFEST files, and the associated security catalog (.cat) files, are important to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Shsetup.dll6.0.6001.22458101,88829-Jun-200914:11x86
Shsetup.dll6.0.6002.22159101,88829-Jun-200911:37x86
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Shsetup.dll6.0.6001.22458122,88029-Jun-200914:26x64
Shsetup.dll6.0.6002.22159122,88029-Jun-200913:44x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Shsetup.dll6.0.6001.22458212,99229-Jun-200914:00IA-64
Shsetup.dll6.0.6002.22159212,99229-Jun-200913:38IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the ComputerName element in Microsoft-Windows-Shell-Setup component on Windows Vista, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbsurveynew, kbqfe, KB973033

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Article Info
Article ID : 973033
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 405