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A computer that is running Windows Server 2008 or Windows Vista may stop responding when an application or service accesses the shared resources by using the SMB protocol


View products that this article applies to.

Symptoms

A computer that is running Windows Server 2008 or Windows Vista may stop responding when one or more applications or services access the shared resources by using the SMB protocol.

Note The issue does not occur if the opportunistic locking (oplock) is disabled.

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Cause

This issue is caused by a deadlock situation in the Redirected Drive Buffering SubSystem (Rdbss.sys) driver.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.



Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

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For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6001.22477225,28023-Jul-200904:02x86

For all supported x86-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22182225,28023-Jul-200904:05x86

For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6001.22477287,74423-Jul-200904:06x64

For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22182288,25623-Jul-200904:09x64
For all supported Itanium-based version of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6001.22477677,37623-Jul-200904:12IA-64

For all supported Itanium-based version of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys6.0.6002.22182678,40023-Jul-200905:02IA-64

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Workaround

To work around the issue, you can disable the opportunistic locking (oplock). To do this, follow the steps in the following Microsoft Knowledge Base article:
296264 Configuring opportunistic locking in Windows

Note The performance for a computer will decrease after the oplock is disabled.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


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Keywords: kb, kbexpertiseinter, kbfix, kbautohotfix, kbsurveynew, kbqfe, kbhotfixserver

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Article Info
Article ID : 972596
Revision : 3
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 313