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A DirectAccess access failure occurs after the DNS servers that are running Windows Server 2008 return empty responses for AAAA queries in a WINS zone


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You click to select the Use WINS forward lookup check box to forward name resolution queries in a Domain Name System (DNS) zone. You configure the DNS zone to forward the name resolution queries to a Microsoft Windows Internet Name Service (WINS) server within an organization.
  • A Windows 7 client tries to connect to the network of the organization by using the DirectAccess feature.
In this scenario, all Windows 7 clients that have the DirectAccess feature deployed lose local name resolution. Additionally, these clients cannot connect to any local resource by using local name resolution.

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Cause

The DNS servers that are running Windows Server 2008 use a "Success/No-records" response to AAAA queries (queries for a host address record in IPv6 address format) if the name does not exist in the WINS database. However, if the name does not exist in the WINS database, the expected response is "Name Error."

In the DirectAccess scenario, clients depend on the "Name Error" response before they fail over to the local name resolution. Therefore, these clients do not fail over to the local name resolution, and these clients cannot access the local network resource.

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Resolution

To resolve the issue, install the following hotfix on DNS servers that are running Windows Server 2008 Service Pack 2 (SP2).

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the DNS server role must be enabled on the computer that is running Windows Server 2008 SP2.

Restart requirement

You do not have to restart the computer after you apply this hotfix. Please stop the DNS Server before you apply this hotfix, and then start the DNS Server after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Cache.dnsNot Applicable3,17903-Apr-200920:42Not ApplicableSP2
Dns.exe6.0.6002.22151510,97611-Jun-200909:52x86SP2
Dnsserver.events.xmlNot Applicable60903-Apr-200920:42Not ApplicableSP2
For all supported x64-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Cache.dnsNot Applicable3,17903-Apr-200920:39Not ApplicableSP2
Dns.exe6.0.6002.22151638,97611-Jun-200910:06x64SP2
Dnsserver.events.xmlNot Applicable60903-Apr-200920:39Not ApplicableSP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the DirectAccess feature, visit the following Microsoft Web site:

http://www.microsoft.com/windows/enterprise/products/directaccess.aspx

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Package_for_kb972516_sc_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,52715-Jun-200914:18Not Applicable
Package_for_kb972516_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42215-Jun-200914:18Not Applicable
Package_for_kb972516_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53115-Jun-200914:18Not Applicable
Package_for_kb972516_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43015-Jun-200914:18Not Applicable
X86_microsoft-windows-dns-server-service_31bf3856ad364e35_6.0.6002.22151_none_5040ea88ed002a7a.manifestNot Applicable163,37611-Jun-200913:56Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-dns-server-service_31bf3856ad364e35_6.0.6002.22151_none_ac5f860ca55d9bb0.manifestNot Applicable163,41811-Jun-200913:57Not Applicable
Package_for_kb972516_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,53715-Jun-200914:18Not Applicable
Package_for_kb972516_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43015-Jun-200914:18Not Applicable
Package_for_kb972516_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54115-Jun-200914:18Not Applicable
Package_for_kb972516_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43815-Jun-200914:18Not Applicable

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB972516

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Article Info
Article ID : 972516
Revision : 2
Created on : 7/6/2009
Published on : 7/6/2009
Exists online : False
Views : 250