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Slow system response together with many other performance issues occur on a virtualization server that is running Windows Server 2008 and that has the Hyper-V role installed


View products that this article applies to.

Symptoms

You are running some Hyper-V virtual machines on a virtualization server that is running Windows Server 2008 and that has the Hyper-V role installed. Over time, you may experience the following symptoms:
  • When you open the Hyper-V Manager, the connection to a virtualization server fails and a red 'X' appears next to the name of the virtualization server.
  • The system responds slowly, and the processes and services on the virtualization server fail and then generate exceptions.
  • The handle count of the Virtual Machine Worker process (Vmwp.exe) is very large.
These symptoms last until you restart the virtualization server.

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Cause

This issue occurs because the Virtual Machine Worker process (Vmwp.exe) releases pointer icons by using a function that causes handle leak. Over time, the system runs out of resources, and then the system stops responding.

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Resolution

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista and Windows Server 2008SP1GDR
    6.0.6001.22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.6002.18xxxWindows Vista and Windows Server 2008SP2GDR
    6.0.6002.22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the original release of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Rdp4vs.dll6.0.6001.22446478,72009-Jun-200912:39x64SP1
Rdp4vs.mofNot Applicable1,06401-Apr-200916:00Not ApplicableSP1
For all supported x64-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Rdp4vs.dll6.0.6002.22149478,72009-Jun-200912:35x64SP2
Rdp4vs.mofNot Applicable1,06403-Apr-200920:43Not ApplicableSP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB972045, kbqfe, kbhotfixserver, kbfix, kbbug, kbsurveynew, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 972045
Revision : 1
Created on : 7/14/2009
Published on : 7/14/2009
Exists online : False
Views : 232