Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error when you run a Fixed Assets integration by using Integration Manager for Microsoft Dynamics GP 10.0: "The Asset ID and Book ID already exist in the FA00200 and updates are not supported on Asset Books at this time"


Symptoms

In Integration Manager for Microsoft Dynamics GP, you receive the following error message when you run a Fixed Assets integration, and there are multiple Suffix IDs for an Asset ID:
The Asset ID and Book ID already exist in the FA00200 table and updates are not supported on Asset Books at this time.

↑ Back to the top


Cause

This problem or behavior occurs when query relationships are incorrect.

↑ Back to the top


Resolution

To resolve this error, add a query relationship on both the Asset ID and the Suffix ID. To do this, follow these steps:
  1. Open Integration Manager and the integration.
  2. Double-click the Query Relationships window to open the window.
  3. Click the Asset ID in the General source, and drag it to the Asset ID in the Book source.
  4. Click the Suffix ID in the General source, and drag it to the Suffix ID.

↑ Back to the top


Keywords: kbnosurvey, kbexpertiseadvanced, kberrmsg, kbsurveynew, kbmbspartner, kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbprb, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 971839
Revision : 1
Created on : 3/3/2017
Published on : 1/9/2015
Exists online : False
Views : 81