Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Locale data is missing in the saved event logs if you archive the event logs on a computer that is running Windows Vista or Windows Server 2008 and that has an MUI for a non-English language installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running an English version of Windows Vista or of Windows Server 2008.
  • You install the Multilingual User Interface Pack (MUI) for a non-English language, and then you change the system display to that of a non-English language.
  • You install a localized application, such as a localized version of Microsoft SQL Server.
  • You archive some event logs. For example, you save the Application log in Event Viewer, or you save the Application log by using event log API functions.
In this scenario, some locale data is missing in the saved event logs. Therefore, the non-English characters in the saved event logs are unexpectedly displayed in English characters instead of in the localized language. Because the monitoring tools expect localized information in the saved event logs, this behavior may cause the tools to miss some target information.

↑ Back to the top


Cause

When you archive event logs, no localization metadata is written if the system uses a localized language that is not a primary localized language.

↑ Back to the top


Resolution

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista and Windows Server 2008SP1GDR
    6.0.6001.22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.6002.18xxxWindows Vista and Windows Server 2008SP2GDR
    6.0.6002.22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the original release of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6001.224391,014,78428-May-200914:35x86
For all supported x86-based versions of Windows Server 2008 SP1 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6002.221411,017,85628-May-200914:30x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6001.224391,490,43228-May-200914:59x64
For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6002.221411,491,96828-May-200914:26x64
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6001.224392,698,24028-May-200914:50IA-64
For all supported Itanium-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wevtsvc.dll6.0.6002.221412,701,82428-May-200914:21IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbhotfixserver, kbqfe, KB971734

↑ Back to the top

Article Info
Article ID : 971734
Revision : 2
Created on : 7/17/2009
Published on : 7/17/2009
Exists online : False
Views : 323