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A Hyper-V differencing disk that you create in Windows Server 2008 R2 cannot be used in Windows Server 2008


View products that this article applies to.

Symptoms

Issue 1

Consider the following scenario:
  • You create a Hyper-V virtual machine on a computer that is running Windows Server 2008.
  • You select to attach a differencing disk that was created on a computer that is running Windows Server 2008 R2.
In this scenario, you may receive the following error messages:
The server encountered an error while configuring hard disk on VMName.
Failed to add device 'Microsoft Virtual Hard Disk'.
Cannot open attachment '<DirectoryName>\Filename.vhd'. Error: 'The file or directory is corrupted and unreadable.'
Cannot get information for attachment '<DirectoryName>\Filename.vhd'.

Issue 2

Consider the following scenario:

  • System Center Virtual Machine Manager 2008 R2 is managing a Windows Server 2008 server that has the Hyper role installed and a Windows Server 2008 R2 server that has the Hyper-V role installed
  • You migrate a Hyper-V virtual machine from Windows Server 2008 R2 to Windows Server 2008.
In this scenario, you may receive the following error message::
Error (1730)
The selected action could not be completed because the virtual machine is not in a state in which the action is valid.

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Cause

This issue occurs because the Vhdparser.sys driver in Windows Server 2008 does not correctly handle a metadata value. This metadata value is used on differencing disks that are created on a server that is running Windows Server 2008 R2.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
Additionally, you must have Hyper-V role installed on your computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

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For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirement
Isoparser.sys6.0.6001.2244519,96808-Jun-200917:43x64SP1
Passthruparser.sys6.0.6001.2244528,67208-Jun-200917:43x64SP1
Storvsp.sys6.0.6001.22445133,12008-Jun-200917:43x64SP1
Vhdparser.sys6.0.6001.2244594,20808-Jun-200917:43x64SP1
Wstorvsp.infNot Applicable6,46208-Jun-200914:59Not ApplicableSP1

For all supported x64-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Isoparser.sys6.0.6002.2214819,96808-Jun-200917:27x64SP2
Passthruparser.sys6.0.6002.2214828,67208-Jun-200917:27x64SP2
Storvsp.sys6.0.6002.22148122,88008-Jun-200917:27x64SP2
Vhdparser.sys6.0.6002.2214887,55208-Jun-200917:27x64SP2
Wstorvsp.infNot Applicable6,46208-Jun-200914:59Not ApplicableSP2

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kb, kbhyperv, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver

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Article Info
Article ID : 971677
Revision : 3
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 256