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Multicast OS deployments fail with a hash value error when the Windows OS WIM file size is larger than 4 GB in System Center Configuration Manager 2007


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a System Center Configuration Manager 2007 Deployment Feature Pack (OSD) task sequence to deploy a Windows OS Windows Management Interface (WIM) file.
  • The file is larger than 4 GB.
  • You use the multicase method to deploy the OS WIM file.
In this scenario, the task sequence and the deployment fails immediatly after the WIM file is downloaded.

Note The same Windows OS WIM file deploys correctly by using unicast. Additionally, this problem will not occur if you use the multicast method to deploy Windows OS WIM files that are smaller than 4 GB.

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Cause

Thisissue is caused by a known problem in System Center Configuration Manager 2007 Service Pack 1 (SP1) R2. In this problem, hash calculations are not performed correctly when the WIM file size is larger than 4 GB.

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Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:
971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have System Center Configuration Manager 2007 Service Pack 1 installed.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Mcs.msiNot Applicable7,138,30401-Dec-200801:15Not Applicable
Smswdstp.dll4.0.6221.1176119,12801-Dec-200801:15x86
Smswdstp.dll4.0.6221.1176286,04001-Dec-200801:15x64

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Workaround

To work around this problem, either use the unicast method to deploy or to use OS WIM files that are smaller than 4 GB.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

After you install the hotfix that is described in Microsoft Knowledge Base (KB) article 971413, multicast OS deployments may no longer work. This includes Windows OS WIM files that are smaller than 4GB.

After you install the hotfix that is described in KB article 971413, a site reset is initiated. A site reset reinstalls all the site components. However, the multicasting session fails if the following conditions are true:
  • A multicasting session is initiated too soon after the site reset procedure.
  • The site reset procedure has not been completed.
  • Not all the components have completed their reinstalation process, in particular the components associated with multicasting.
The easiest way to resolve this problem is to wait awhile before you perform any multicast OS deployment. However, if multicasting deployment is still not working, follow the methods described here:

Method 1

  1. In the properties of the OS image, disable and then re-enable the Allow this package to be transferred via multicast (WinPE only) option.
  2. Disable and then re-enable the Multicastoption in the properties of the multicast distribution point (DP).
  3. Reinstall WDS.
Note If multicast deployment on files larger than 4 GB is still not working, follow the next method.

Method 2

  1. In the System Center Configuration Manager 2007 console, under Operating System Images, right-click the OS Image that is being multicasted, and then click Properties.
  2. Click the Distribution Settingstab.
  3. Clear the Allow this package to be transferred via multicast (WinPE only) option, and then click
    Apply.
  4. Check the Allow this package to be transferred via multicast (WinPE only) option, and then click
    OK.
  5. Repeat steps 1 to step 4 for each OS image that have being set for multicast.
Note If multicast deployment on files larger than 4 GB is still not working, follow the next method.

Method 3

  1. In the System Center Configuration Manager 2007 console, under Operating System Images, right-click the OS Image that is being multicasted and then click Properties.
  2. Click the Distribution Settingstab.
  3. Clear the Allow this package to be transferred by using multicast (WinPE only) option, and then click OK.
  4. Repeat steps 1 to step 3 of this method for each OS image that have have being set for multicast.
  5. Disable the multicast DP in the properties of the DP role. To do this, click the Multicast tab, clear the Enable Multicast option, and then click OK.
  6. Monitor the MCSSetup.log file and the MCSMSI.log file. Wait until the files are uninstalled successfully.
  7. Reinstall multicast in the properties of the DP role. To do this, click the Multicast tab, check Enable Multicast, and then click OK.
  8. Monitor the MCSSetup.log file and the MCSMSI.log file. Wait until the files are installed successfully.
  9. In the System Center Configuration Manager 2007 console, under Operating System Images, right-click the OS Image that is being multicasted and then click Properties.
  10. Click the Distribution Settingstab.
  11. Check the Allow this package to be transferred via multicast (WinPE only) option, and then click
    OK.
  12. Repeat steps 9 to step 11 of this method for each OS image that have beingset to multicast.
Note If multicast deployment on files larger than 4 GB is still not working, follow the next method.

Method 4

  1. Follow steps 1 to step 6 of Method 3.
  2. If the server is not a PXE Service Point, go to step 5 of this method.
  3. If the server is also a PXE Service Point, delete the boot images from the PXEBOOTIMAGES$ DP and uninstall the ConfigMgr PXE service point role.
  4. Monitor the PXESetup.log file and make sure that the PXE service point is uninstalled correctly.
  5. Uninstall WDS.
  6. If you are prompted, restart the server.
  7. Reinstall WDS to make sure that you select both the Deployment Server and the Transport Server.
  8. If the server is not a PXE Service Point, go to step 12 of this method.
  9. If the server is also a PXE Service Point, reinstall the ConfigMgr PXE service point role.
  10. Monitor the PXESetup.log file and make sure that the PXE service point is installed correctly. If the log prompts to restart the server, restart the server.
  11. Add the boot images back to the PXEBOOTIMAGES$ DP.
  12. Follow steps 7 to step 13 of Method 3.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbsurveynew, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kb, kbexpertiseinter

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Article Info
Article ID : 971413
Revision : 4
Created on : 4/10/2020
Published on : 4/10/2020
Exists online : False
Views : 430