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Error message when an application tries to write data to a shared file if another application has read-only access to the same file on a computer that is running Windows Server 2003: "Delayed Write Failed"


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a shared file on a computer that is running Windows Server 2003.
  • Two applications access this shared file concurrently. One application has write access to the file, and the other application has read-only access to the file.
After both applications run for some time, such as several hours, the application that has write access cannot write data to the shared file, and this application receives the "Delayed Write Failed" error message. This problem causes data loss or data corruption in the shared file.

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Cause

This problem occurs because of a timing issue in the Redirected Drive Buffering SubSystem (Rdbss.sys) driver. When the timing issue occurs, the cache data of the shared file is flushed by using the wrong File object. This File object has read-only access.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP1
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.3377177,66415-Jul-200915:10x86
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.4552177,66415-Jul-200914:58x86
For all supported x64-based versions of Windows Server 2003 and of Windows XP
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.3377309,24816-Jul-200914:12x64
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.4552309,76016-Jul-200914:18x64
For all supported Itanium-based versions of Windows Server 2003 SP1
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.3377487,93616-Jul-200914:12IA-64
For all supported Itanium-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Rdbss.sys5.2.3790.4552487,93616-Jul-200914:16IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB971295

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Article Info
Article ID : 971295
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 239