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Users who are members of the Power Users group or of the Print Operators group cannot install the local printers on a server that is running Windows Server 2008


View products that this article applies to.

Symptoms

After you have installed the Print Server role service on a computer that is running Windows Server 2008, you can use only an administrator user account to perform certain tasks that are related to printing. These tasks include the installation of local print queues, of local print ports, and of local printer drivers.

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Cause

A hard-coded check prevents domain users from using most of the tasks that are related to printing.

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Resolution

After you install this hotfix, you have a new
Security tab in the Print Server properties. On this
Security tab, you can use the Administrator account to assign the domain user permission to perform the tasks that are related to printing. There are several limitations after this hotfix is installed. These limitations include the following:
  • A delegated user can install only those print drivers that are already in the driver store.
  • A delegated user cannot install a print driver from the driver store remotely.
  • A delegated user cannot install a print driver from the driver store in a clustered spooler.
  • A delegated user cannot install a print queue remotely and cannot add a printer remotely from a computer that is running Windows XP.


    Note If the delegated user uses a computer that is running Windows 7 or Windows Vista, the delegated user can install a print queue remotely and can add a printer remotely.
Note By default, a delegated user does not have permission to manage the printers that are installed on the print server. However, after you assign a delegated user permission to the print server, that user does not require additional permission to manage any printers that are added later.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.


Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

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For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6001.22467637,44010-Jul-200911:59x86SP1
Printui.dll6.0.6001.22467873,47210-Jul-200911:59x86SP1
For all supported x86-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6002.22169624,12810-Jul-200911:48x86SP2
Printui.dll6.0.6002.22169873,47210-Jul-200911:49x86SP2
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6001.224671,624,57610-Jul-200911:56IA-64SP1
Printui.dll6.0.6001.224671,648,64010-Jul-200911:57IA-64SP1
For all supported Itanium-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6002.221691,624,57610-Jul-200911:40IA-64SP2
Printui.dll6.0.6002.221691,648,64010-Jul-200911:42IA-64SP2
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6001.22467793,08810-Jul-200912:26x64SP1
Printui.dll6.0.6001.22467987,13610-Jul-200912:26x64SP1
For all supported x64-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatformSP requirement
Localspl.dll6.0.6002.22169774,14410-Jul-200911:54x64SP2
Printui.dll6.0.6002.22169987,13610-Jul-200911:55x64SP2

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
940724 Members of the Power Users group and of the Print Operators group cannot install local printers on a Windows Server 2003-based member server


For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kb, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver

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Article Info
Article ID : 971222
Revision : 3
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 155