Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may encounter an SIS data loss issue after SIS links that were backed up on a computer that is running Windows Storage Server 2003 are restored on a computer that is running Windows Storage Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable single instance storage (SIS) for a disk volume on a computer that is running Windows Storage Server 2003.
  • SIS links are created for some files in the common store located on the disk volume.
  • You reduce the size of some files in the common store from more than 32 kilobytes (KB) to less than 1 KB.
  • You back up the SIS links, and then you restore these SIS links to a SIS-enabled volume on a computer that is running Windows Storage Server 2008.
In this scenario, the restored SIS links point to nothing. Therefore, you encounter a data loss issue.

↑ Back to the top


Cause

This issue occurs because of the SIS restore module (Sisbkup.dll). This module changes an SIS link that points to a file that is smaller than 1KB to a normal file in the initial phases of the SIS restore on a computer that is running Windows Storage Server 2008. Later the restore API tries to fix the file by adding a reparse point to it. However, because the link has already been converted to a normal file, the SIS link points to nothing.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

You do not have to make any change to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista file information note
The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Sisbkup.dll6.0.6001.2243120,48012-May-200915:42x86
Sisbkup.dll6.0.6002.2213420,48012-May-200913:08x86
For all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Sisbkup.dll6.0.6001.2243125,60012-May-200916:06x64
Sisbkup.dll6.0.6001.2243125,60012-May-200916:06x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Sisbkup.dll6.0.6001.2243164,51212-May-200915:46IA-64
Sisbkup.dll6.0.6002.2213464,51212-May-200915:33IA-64

↑ Back to the top


More information

For more information about the known issues in Windows Storage Server 2008, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Package_for_kb971191_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42113-May-200905:39Not Applicable
Package_for_kb971191_sc_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36113-May-200905:39Not Applicable
Package_for_kb971191_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,70113-May-200905:39Not Applicable
Package_for_kb971191_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42513-May-200905:39Not Applicable
Package_for_kb971191_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36513-May-200905:39Not Applicable
Package_for_kb971191_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71313-May-200905:39Not Applicable
X86_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6001.22431_none_5d5177a876d15d58.manifestNot Applicable4,15612-May-200919:26Not Applicable
X86_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6002.22134_none_5f3aea6e73f4fe81.manifestNot Applicable4,15612-May-200919:23Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6001.22431_none_b970132c2f2ece8e.manifestNot Applicable4,16612-May-200919:26Not Applicable
Amd64_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6002.22134_none_bb5985f22c526fb7.manifestNot Applicable4,16612-May-200919:21Not Applicable
Package_for_kb971191_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42913-May-200905:39Not Applicable
Package_for_kb971191_sc_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,36913-May-200905:39Not Applicable
Package_for_kb971191_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,71113-May-200905:39Not Applicable
Package_for_kb971191_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43313-May-200905:39Not Applicable
Package_for_kb971191_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37313-May-200905:39Not Applicable
Package_for_kb971191_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72313-May-200905:39Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6001.22431_none_5d531b9e76cf6654.manifestNot Applicable4,16112-May-200919:10Not Applicable
Ia64_microsoft-windows-sisbkup_31bf3856ad364e35_6.0.6002.22134_none_5f3c8e6473f3077d.manifestNot Applicable4,16112-May-200919:03Not Applicable
Package_for_kb971191_sc_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42513-May-200905:39Not Applicable
Package_for_kb971191_sc_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,36413-May-200905:39Not Applicable
Package_for_kb971191_sc~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,70613-May-200905:39Not Applicable
Package_for_kb971191_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42913-May-200905:39Not Applicable
Package_for_kb971191_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,36813-May-200905:39Not Applicable
Package_for_kb971191_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71713-May-200905:39Not Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbarchive, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbnosurvey, KB971191

↑ Back to the top

Article Info
Article ID : 971191
Revision : 3
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 219