Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Windows Server 2003 stops responding (hangs) during a shutdown if SharePoint Services Tracing is enabled


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run Microsoft Office SharePoint Server 2007 on a computer that is running Windows Server 2003.
  • You enable SharePoint Services Tracing on the computer.
  • The computer has multiple processing units.
  • You try to shut down the computer.
In this scenario, the computer stops responding (hangs), and the shutdown process is not completed.

↑ Back to the top


Cause

This problem occurs because a reference count is managed incorrectly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Installation instructions

After you install this hotfix, we recommend that you additionally install hotfix 978243. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
978243� A terminal server that is running Windows Server 2003 Service Pack 2 restarts unexpectedly after hotfix 971280 or security update 971486 (MS09-058) is installed

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.2.3790.45252,499,58408-Jun-200915:54Not ApplicableSP2
Ntkrnlpa.exe5.2.3790.45252,310,65608-Jun-200914:36x86SP2
Ntkrpamp.exe5.2.3790.45252,351,10408-Jun-200914:36Not ApplicableSP2
Ntoskrnl.exe5.2.3790.45252,458,11208-Jun-200915:53x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4354280,06408-Jun-200918:26x64SP2
Ntkrnlmp.exe5.2.3790.45254,613,12008-Jun-200918:26x64SP2
Ntoskrnl.exe5.2.3790.45254,540,41608-Jun-200918:26x64SP2
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.44551,646,59208-Jun-200918:22IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.45256,581,24808-Jun-200918:22IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4455775,16808-Jun-200918:22x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbsurveynew, kbbug, kbfix, kbqfe, KB971067

↑ Back to the top

Article Info
Article ID : 971067
Revision : 5
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 239