Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot stop safely a removable storage device on a computer that is running Windows Server 2003 after you delete a folder on the removable storage device


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You connect a removable storage device to a computer that is running Windows Server 2003. For example, you connect a USB device or an IEEE 1394 device to the computer.
  • You delete a folder on this device. In this folder, the total number of files and subfolders is a multiple of four, such as 180.
  • You click Stop on the Safely Remove Hardware icon in the notification area to remove this device.
In this scenario, you cannot stop this device, and you receive the following error message:
The device 'generic volume' cannot be stopped because a program is still accessing it

↑ Back to the top


Cause

This issue occurs because a reference to a file object is not released correctly.

↑ Back to the top


Resolution

Hotfix information for Windows Server 2003

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2003 SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.3339592,38407-May-200912:59x86
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4509592,38407-May-200913:49x86
For all supported Itanium-based versions of Windows Server 2003 SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.33391,886,72007-May-200914:11IA-64
For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.45091,890,81607-May-200914:18IA-64
For all supported x64-based versions of Windows Server 2003 and of Windows XP
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.33391,127,42407-May-200914:11x64
For all supported x64-based versions of Windows Server 2003 SP2 and of Windows XP SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.45091,046,01607-May-200914:21x64

↑ Back to the top


Workaround

To work around this issue, you restart the computer.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB970998

↑ Back to the top

Article Info
Article ID : 970998
Revision : 1
Created on : 7/13/2009
Published on : 7/13/2009
Exists online : False
Views : 249