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The Group Policy Management MMC snap-in stops responding on a computer that is running Windows Vista or Windows Server 2008 when you select a Group Policy object in a domain that has lots of organizational units


View products that this article applies to.

Symptoms

Consider the following scenario. You have a computer that is running Windows Vista or Windows Server 2008. You use the Group Policy Management snap-in of Microsoft Management Console (MMC) to browse Group Policy objects. However, when you select a Group Policy object, the Group Policy Management MMC snap-in responds slowly or even stops responding. In this scenario, you have to wait awhile before the MMC snap-in responds again.

Note This problem usually occurs in a domain that has lots of organizational units (OUs). For example, you select a Group Policy object in a domain that has more than 100,000 OUs. In this example, it may take the Group Policy Management MMC snap-in about a half hour to resume responsiveness.

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Cause

When you select a Group Policy object in the Group Policy Management MMC snap-in, the MMC snap-in lists all the OUs that are linked to the selected Group Policy object. To list the linked OUs, the Group Policy Management MMC snap-in queries all OUs in the domain. Then, the MMC snap-in iterates through the OUs to find OUs that are linked to the selected Group Policy object. This behavior takes a long time to complete if the domain has lots of OUs.

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Resolution

Hotfix information

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix on a computer that is running Windows Vista, you must have Windows Vista Service Pack 1 (SP1) or Windows Vista Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791� How to obtain the latest Windows Vista service pack

No prerequisites are required for computers that are running Windows Server 2008.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.0.6000.16xxxWindows VistaRTMGDR
    6.0.6000.20xxxWindows VistaRTMLDR
    6.0.6001.18xxxWindows Vista and Windows Server 2008SP1GDR
    6.0.6001.22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.6002.18xxxWindows Vista and Windows Server 2008SP2GDR
    6.0.6002.22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 (SP1) is integrated into the original release of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Microsoft.grouppolicy.serveradmintools.reporting.dll6.0.6001.224341,654,78415-May-200914:42x86SP1
Gpmgmt.dll6.0.6001.224341,665,02415-May-200912:59x86SP1
Gprsop.dll6.0.6001.22434452,60815-May-200912:59x86SP1
For all supported x86-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Microsoft.grouppolicy.serveradmintools.reporting.dll6.0.6002.221371,654,78415-May-200914:24x86SP2
Gpmgmt.dll6.0.6002.221371,665,02415-May-200912:50x86SP2
Gprsop.dll6.0.6002.22137452,60815-May-200912:50x86SP2
For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Gpmgmt.dll6.0.6001.224342,312,19215-May-200913:15x64SP1
Gprsop.dll6.0.6001.22434481,79215-May-200913:15x64SP1
Microsoft.grouppolicy.serveradmintools.reporting.dll6.0.6001.224341,654,78415-May-200914:42x86SP1
For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Gpmgmt.dll6.0.6002.221372,312,19215-May-200912:49x64SP2
Gprsop.dll6.0.6002.22137481,79215-May-200912:49x64SP2
Microsoft.grouppolicy.serveradmintools.reporting.dll6.0.6002.221371,654,78415-May-200914:24x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kbfix, kbhotfixserver, kbqfe, KB970964

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Article Info
Article ID : 970964
Revision : 1
Created on : 7/15/2009
Published on : 7/15/2009
Exists online : False
Views : 330