Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A memory leak issue occurs if you call the WTSQuerySessionInformation function to query the published applications information or the initial program information for session ID 0


View products that this article applies to.

Symptoms

Consider the following scenario:
  • An application or a service calls the WTSQuerySessionInformation function to query some terminal server session related information.
  • The second parameter is 0 and the third parameter is WTSInitialProgram or WTSApplicationName.
In this scenario, under heavy stress conditions, the memory usage of the application or the service keeps increasing.
Further investigation indicates that the WTSQuerySessionInformation function leaks memory. Additionally, the GetLastError function returns an incorrect error code.

↑ Back to the top


Cause

This issue occurs because, when the WTSQuerySessionInformation function is used under a heavy stress situation, a structure is not freed, and the last error is not logged. This behavior occurs when the WTSQuerySessionInformation function is used to query the published applications information or the initial program information for session ID 0.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2003 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll5.2.3790.451619,45620-May-200900:09x86
For all supported x64-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wtsapi32.dll5.2.3790.451629,69619-May-200922:03x64SP2Not Applicable
Wwtsapi32.dll5.2.3790.451619,45619-May-200922:03x86SP2WOW
For all supported Itanium-based versions of Windows Server 2003 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wtsapi32.dll5.2.3790.451654,78419-May-200922:03IA-64SP2Not Applicable
Wwtsapi32.dll5.2.3790.451619,45619-May-200922:03x86SP2WOW
For all supported x64-based versions of Windows XP SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wtsapi32.dll5.2.3790.451629,69619-May-200922:03x64SP2Not Applicable
Wwtsapi32.dll5.2.3790.451619,45619-May-200922:03x86SP2WOW
For all supported x86-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6001.2242526,62404-May-200912:21x86
For all supported x86-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6002.2212826,62404-May-200912:22x86
For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6001.2242570,65604-May-200912:30IA-64
For all supported Itanium-based versions of Windows Server 2008 SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6002.2212870,65604-May-200912:14IA-64
For all supported x64-based versions of Windows Server 2008 and of Windows Vista SP1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6001.2242531,23204-May-200912:41x64
For all supported x64-based versions of Windows Server 2008 SP2 and of Windows Vista SP2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wtsapi32.dll6.0.6002.2212831,23204-May-200912:19x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the WTSQuerySessionInformation function, visit the following Microsoft Web site:

http://msdn.microsoft.com/en-us/library/aa383838(VS.85).aspx For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB970910

↑ Back to the top

Article Info
Article ID : 970910
Revision : 3
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 721