Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to offer Remote Assistance from an expert computer that is running Windows Server 2008 or Windows Vista: "Windows Remote Assistance is closing"


View products that this article applies to.

Symptoms

On an expert computer that is running Windows Server 2008 or Windows Vista, you try to offer Remote Assistance to a novice computer. However, the operation fails, and you receive the following error message:
Windows Remote Assistance is closing. An unknown error occurred so the session was disconnected.

Try restarting your session. If you continue to get this message, contact your administrator or technical support.
Additionally, the following event is logged in the Application log on the expert computer:


Source: Microsoft-Windows-RemoteAssistance
Date: Time
Event ID: 3
Task Category: None
Level: Critical
Keywords:
User: User
Computer: Computer
Description: Application will terminate, a critical error was detected in File Path

↑ Back to the top


Cause

Remote Assistance (Msra.exe) uses the RDP collaboration component (Rdpencom.dll) to establish a connection between the expert computer and the novice computer. When it tries to establish the connection, Remote Assistance uses an IPv4 address to fill a buffer that is intended to hold an IPv6 address. This behavior breaks the connection.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problemP1 that P2 described in this article. Apply this hotfix only to systems that are experiencing the problemP1 described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must run one of the following:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2
  • Windows Vista Service Pack 1
  • Windows Vista Service Pack 2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel. The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately . MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatformSP requirement
Rdpencom.dll6.0.6001.22428612,86408-May-200913:15x86SP1
Rdpencom.mofNot Applicable1,06601-Apr-200918:56Not ApplicableSP1
Rdpencom.dll6.0.6002.22131612,86408-May-200913:06x86SP2
Rdpencom.mofNot Applicable1,06603-Apr-200920:49Not ApplicableSP2
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatformSP requirement
Rdpencom.dll6.0.6001.22428708,09608-May-200913:29x64SP1
Rdpencom.mofNot Applicable1,06601-Apr-200916:00Not ApplicableSP1
Rdpencom.dll6.0.6002.22131708,09608-May-200912:57x64SP2
Rdpencom.mofNot Applicable1,06603-Apr-200920:43Not ApplicableSP2

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Package_for_kb970907_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36712-May-200911:07Not Applicable
Package_for_kb970907_client_2~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53012-May-200911:07Not Applicable
Package_for_kb970907_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71212-May-200911:07Not Applicable
Package_for_kb970907_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42512-May-200911:07Not Applicable
Package_for_kb970907_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,53012-May-200911:07Not Applicable
Package_for_kb970907_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71312-May-200911:07Not Applicable
X86_microsoft-windows-t..s-collaboration-api_31bf3856ad364e35_6.0.6001.22428_none_45ed352fb66c9f12.manifestNot Applicable82,30108-May-200916:58Not Applicable
X86_microsoft-windows-t..s-collaboration-api_31bf3856ad364e35_6.0.6002.22131_none_47c1d525b3a15ec6.manifestNot Applicable82,30108-May-200917:00Not Applicable
Additional files for all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-t..s-collaboration-api_31bf3856ad364e35_6.0.6001.22428_none_a20bd0b36eca1048.manifestNot Applicable82,34108-May-200916:59Not Applicable
Amd64_microsoft-windows-t..s-collaboration-api_31bf3856ad364e35_6.0.6002.22131_none_a3e070a96bfecffc.manifestNot Applicable82,34108-May-200917:05Not Applicable
Package_for_kb970907_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37512-May-200911:07Not Applicable
Package_for_kb970907_client_2~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54012-May-200911:07Not Applicable
Package_for_kb970907_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72212-May-200911:07Not Applicable
Package_for_kb970907_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43312-May-200911:07Not Applicable
Package_for_kb970907_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,54012-May-200911:07Not Applicable
Package_for_kb970907_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72312-May-200911:07Not Applicable

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB970907

↑ Back to the top

Article Info
Article ID : 970907
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 299