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On a Windows Server 2003-based terminal server, terminal service-related settings may not be effective if the "Process even if the group policy objects have not changed" option is enabled for Registry Policy Processing


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Windows Server 2003-based terminal server, you configure some Group Policy settings under the following node in Group Policy Object Editor:
    Computer Configuration\Administrative Templates\Windows Components\Terminal Services
  • You enable the "Registry Policy Processing" Group Policy setting, and you enable the "Process even if the group policy objects have not changed" option.

    Note The "Registry Policy Processing" Group Policy setting is under the following node:
    Computer Configuration\Administrative Templates\System\Group Policy
In this scenario, the terminal service-related Group Policy settings are sometimes not applied to some users who log on to the terminal server.

For example, a Group Policy setting in the Terminal Services node that is mentioned here may mandate a home drive and home path. When the issue occurs, the user will not have a home drive after logging on to the terminal server. Or, the user will use the home drive mapping that is specified in the domain account.

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Cause

This problem occurs because of a timing issue in the terminal services policy engine.

The timing issue usually occurs when the "Process even if the group policy objects have not changed" option is enabled for the "Registry Policy Processing" Group Policy setting.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Regapi.dll5.2.3790.334056,83209-May-200908:10x86SP1
Termsrv.dll5.2.3790.3340246,27209-May-200908:10x86SP1
Windows Server 2003 Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Regapi.dll5.2.3790.451056,83208-May-200922:17x86SP2
Termsrv.dll5.2.3790.4510246,27208-May-200922:17x86SP2
Windows Server 2003 Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.3340144,89608-May-200917:16IA-64SP1Not Applicable
Termsrv.dll5.2.3790.3340698,36808-May-200917:16IA-64SP1Not Applicable
Wregapi.dll5.2.3790.334056,83208-May-200917:16x86SP1WOW
Windows Server 2003 Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.4510144,89608-May-200917:21IA-64SP2Not Applicable
Termsrv.dll5.2.3790.4510698,88008-May-200917:21IA-64SP2Not Applicable
Wregapi.dll5.2.3790.451056,83208-May-200917:21x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.3340111,61608-May-200917:16x64SP1Not Applicable
Termsrv.dll5.2.3790.3340365,05608-May-200917:16x64SP1Not Applicable
Wregapi.dll5.2.3790.334056,83208-May-200917:16x86SP1WOW
Windows Server 2003 Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Regapi.dll5.2.3790.4510111,61608-May-200917:25x64SP2Not Applicable
Termsrv.dll5.2.3790.4510365,05608-May-200917:25x64SP2Not Applicable
Wregapi.dll5.2.3790.451056,83208-May-200917:25x86SP2WOW

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Workaround

To work around this problem, disable the "Process even if the group policy objects have not changed" option for the "Registry Policy Processing" Group Policy setting.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the "Registry Policy Processing" Group Policy setting, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 � Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver, KB970870

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Article Info
Article ID : 970870
Revision : 1
Created on : 6/4/2009
Published on : 6/4/2009
Exists online : False
Views : 268