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FIX: A Target server receives only the last message when you use a BizTalk FileAct adapter to send over PUT FILE requests that have the same "Sw:LogicalName" logical name specified in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

When you use the Microsoft BizTalk FileAct and InterAct Adapters for SWIFT 2.3 Service Pack 1 (SP1) in Microsoft BizTalk Server 2006 R2, you may experience the following two issues:

Issue 1: A Target server receives only the last message when the BizTalk FileAct adapter sends PUT FILE requests that have the same "Sw:LogicalName" logical name to a target server

Consider the following scenario:
  • In BizTalk Server 2006 R2, you use the BizTalk FileAct adapter to concurrently send PUT FILE requests to a target server.
  • You specify the "Sw:LogicalName" logical name to be the same in all PUT FILE requests.
In this scenario, the target server receives only the last message. All other files that have the same logical name are overwritten.

Issue 2: A BizTalk FileAct adapter does not send back an Acknowledgement (ACK) correctly when the BizTalk FileAct adapter receives a file from a sender and a delivery notification is required by the sender

Consider the following scenario:
  • You use a BizTalk FileAct adapter to receive a file from a sender.
  • A delivery notification is required by the sender.

In this scenario, the BizTalk FileAct adapter does not generate a correct Acknowledgement(ACK). The ACK is not sent back to the sender client.

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Cause

Cause of Issue 2

When the BizTalk FileAct adapter generates the elements "RequestType", "Responder" and "Service" for an ACK, the adapter does not reuse the information from the client message.

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Resolution


Issue 1

You can send PUT FILE requests that have the same "Sw:LogicalName" logical name after you apply this hotfix.

Issue 2

After you apply this hotfix, the BizTalk FileAct adapter generates the elements "RequestType", "Responder" and "Service" for an ACK by using the correct information from the client message as follows:
  • The "RequestType" element uses the value in "Sw:AckServerInfo" from the client message.
  • The "Responder" element of the ACK uses the value in "Sw:AckServerInfo" from the client message.
  • The "Service" element of the ACK uses the value in "Sw:FileRequestHeader" from the client message.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the BizTalk FileAct and InterAct Adapters for SWIFT 2.3 SP1 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the BizTalk Server Host Instance after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.solutions.financialservices.swift.adapter.common.dll2.3.3009.0186,29630-Mar-200909:23x86
Microsoft.solutions.financialservices.swift.adapter.receiver.dll2.3.3009.067,52030-Mar-200909:23x86
Microsoft.solutions.financialservices.swift.fileactadaptermanagement.dll2.3.3009.0161,74430-Mar-200909:23x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the FileAct and InterAct adapters, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: kbexpertiseadvanced, kbautohotfix, kbbtsadapters, kbbiztalk2006r2sp1fix, kbsurveynew, kbqfe, KB970194

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Article Info
Article ID : 970194
Revision : 2
Created on : 10/7/2011
Published on : 10/7/2011
Exists online : False
Views : 492